On my iPhone I see a list of songs I cannot delete. Here's what I tried:

  • Go to settings -> memory usage -> iTunes -> delete all music
  • Disable iTunes Match
  • Disable show all music
  • Connect to iTunes on the Mac and manually remove all synced songs
  • Swipe to delete does not work
  • The songs do not show any sort if cloud icons

iTunes shows 3.3GB of Audio on my device which I cannot get rid of.

Any other ideas what to try?

  • I’ve had this problem for a years and i’ve tried nearly everything to resolve it. I’ve restored countless times used all the Explorer apps to manually delete files. I have zombie songs on my iPhone with cloud music turned off. Interestingly/infuriatingly iTunes on my Mac mini shows a different set of songs and my Macbook Pro shows yet ANOTHER completely different set of songs! If I delete them in iTunes with manually manage music on iTunes lies about updating my iPhone but the songs remain. I should mention that they are the greyed out like they are syncing but they never do.
    – DeanDMX
    Mar 21, 2015 at 11:58

1 Answer 1


I finally fixed it by restoring from an iCloud backup. But I read that this does not seem to work for some users.

I personally think, iTunes' quality is really bad and I'm tempted to move over to Amazon's music service but I love the Apple ecosystem and they probably have other issues. Sigh.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .