2

I am running Remote Desktop to connect from my MacBook Air with Yosemite to a Windows computer running Windows 8.1.

Both my Mac and the Windows computer is configured with Norwegian keyboard layout. It seems "\" backslash is impossible to input in this keyboard configuration. I would guess it's the same for Danish and Swedish keyboards.

Is there a way to easily input this character in RDP for Mac using this keyboard layout?

(I would be willing to map some key combination if that's possible, but I don't want to switch to some other keyboard layout, since I need to input Norwegian characters now and then)

  • 2
    So neither option+shift+7 nor the topmost rightmost key work? – Tom Gewecke Mar 18 '15 at 20:25
  • No, none of these work in an RDP session – Svein Fidjestøl Mar 18 '15 at 20:27
  • The irritating thing about RDP is you cannot 'pre-map', you have to find the key that actually will work for Windows. UK keyboard, Mac is 3 keys right of L ; ' Windows is very bottom-left, next to z – Tetsujin Mar 18 '15 at 20:28
  • I do not use Norwegian keyboard therefore my the question is "If", If you use the "keyboard viewer" press shit+alt then mouse click on the backslash \ that should work – Ruskes Mar 18 '15 at 21:07
  • What worked for me was left command plus * (or ') (the key exactly left of the enter key on a macbook pro). it may be depending on having citrix receiver in between, that also has some settings. – Vincent Gerris Mar 16 '17 at 9:54

11 Answers 11

3

The problem was actually a bug in Remote Desktop for OS X, and has been fixed in 8.0.15, which was released a few days ago. Now the keyboard works completely as expected with both my Mac and the Windows computer configured with Norwegian keyboard layout.

enter image description here

2

When you are in the Windows RDP app you should be able to type in the Alt-Code for "\" (Alt-92) no matter which input source you have set. It's not ideal, but should get the job done!

Simply hold down the option/alt key and type 92.

For the record the Alt-Codes don't work in Mac apps.

http://en.wikipedia.org/wiki/Alt_code

You can find a full list of Alt-Codes at alt-codes.net

1

I use two languages, English and Romanian, and the keyboard is Romanian. From the language menu in the menu bar, you can click on the flag (if you dont't see it, just check System Preferences, Keyboard, Input Sources > Show Input menu in menu bar) and select Show keyboard viewer.

If you press CMD, Alt or fn, some keys from the keyboard viewer will change. Locate the "\" character in the viewer, it must show up when pressing one of the keys mentioned above. Then, to type the character, simple press the corresponding CMD/ALT/fn key + the key from the keyboard that changed beforehand.

Also check this Apple Support page: OS X Yosemite: Use the Keyboard Viewer

1

shift+alt+7 under swedish pro keyboard layout

0

As a workaround (which I'd love to have something better than) I've found that finding an existing backslash and doing a copy/paste of it to the new location works, but is obviously very clunky and not a permanent fix.

0

a quick workaround is to just copy and paste from your local machine. I found however CTRL+ALT+~ produces the backslash quickly

0

Try Alt + ?. It is working for me with Swedish Keyboard.

0

Try pressing Shift twice, the \ key then seems to work in RDP

  • 2
    Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 7 '16 at 16:39
0

Ctrl Option 8 did the trick on French Keyboard Layout (OS X and Remote Windows)

-1

ctrl-alt-+ works for me, Swedish keyboard

-1

shift+Insert Key

for back slash key on remote machines "\"

  • Macs don't have an Insert key. – Tetsujin Sep 22 '16 at 11:01

You must log in to answer this question.

protected by Tetsujin Sep 22 '16 at 11:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .