5

Background

Among the many promising features of OS X 10.10 grouped under the label "Continuity" is the ability to make and answer iPhone calls from the Mac. The Mac uses the iPhone's connection to the carrier's voice network. I think this technology works over wifi.

Problem

I'm able to answer calls, but not make them. The error message I receive on my Mac is, "iPhone calls not available. Your iPhone must use the same iCloud and FaceTime account."

What I've done

I've confirmed that both iCloud and FaceTime on my iPhone—as well as iCloud on my Mac—are logged into the same account.

Question

What could be causing this issue, and what should I do to fix it?

  • Try signing out and then back in to iCloud (FaceTime at least) on your computer. – bassplayer7 Mar 19 '15 at 3:09
  • 1
    I have the same problem. Clearly, this is a BUG - the requirements for making and receiving calls are identical, and hence either both should work or neither. There may of course be a workaround for the bug, but hopefully Apple won't drag its feet for too long before fixing it (and hopefully fix it in such a way that we who experience the problem need do nothing and just see the problem go away). – The Dag Apr 9 '15 at 7:48
1

Try completely logging out of your Apple ID/Account, everywhere (every setting/option where you can do so), on both of your devices.

For example, on iOS, you should try signing out from iCloud, iMessage and FaceTime:

  • Settings → iClound → Sign Out
  • Settings → Messages → Send & Receive → Apple ID: ... → Sign Out
  • Settings → FaceTime → Apple ID: ... → Sign Out

Then try logging back into your Apple ID/Account on them and setting it up again.

Hope this helps :)

-James

  • While this might work, @jtrag, I'm holding out for a more elegant solution. However, I fear that you've presented the best solution Apple's crazy-making iCloud/AppleID cluster will allow. – Crowder Mar 22 '15 at 2:07
  • If someone has done this and found it working, please post the step-by-step so us lazy folks don't have to do the "try to find every setting that might be relevant" bit. With a list of "tap this, tap that" and the knowledge this was likely to resolve the problem I'd have a go, but this looks like just an idea that maybe possibly might make some difference somehow. – The Dag Apr 9 '15 at 7:52
  • I tried this and it helped. I first signed out of iCloud (Settings → iClound → Sign Out). I chose to delete all the data from the phone. Then I signed out from iMessage and FaceTime (Settings → Messages → Send & Receive → Apple ID: ... → Sign Out and Settings → FaceTime → Apple ID: ... → Sign Out). After that I logged in to iCloud, Messages and FaceTime. The difference for me was that now my phone number appeared in Messages and FaceTime, whereas there was only my email before. – Damir Zekić Nov 23 '15 at 11:38
0

All you need to do is turn your firewall off. I did it and outgoing calls just work as well as incoming.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .