0

When somebody sends me an e-mail that is marked as "High priority" it does not show up any differently than other e-mails. I am expecting to see a red flag or other indicator to show that the e-mail has been marked by the sender (which could, for instance, be my boss) as more important or urgent and in need of immediate attention. Other e-mail clients I have used in the past did this automatically.

I have poked around a bit in the preferences and in the menus but I haven't found anything to enable such a feature. How do I enable Apple's default mail app to show me the information in the overview of my messages? (My mail window comes up with mailboxes/folders on the left, followed by a list of e-mail summaries (sender, date, subject, and the first few words of the e-mail) to the right of that, and on the right is the actual contents of whatever message is selected. I don't see any indication of priority anywhere.

Technical note: the sender is setting the following headers to indicate priority:

X-Priority: 1 (Highest)
X-MSMail-Priority: High
Importance: High
1
  • It used to show !! in the Flags column - doesn't seem to any more
    – Tetsujin
    Mar 17 '15 at 17:32
3

My recommendation is to use Apple Mail's rules to customize how you want these displayed—you can make them stand out even more than a simple !! in the message list by setting up a Rule in Preferences:

Screen shot of Apple Mail Preferences Rules pane

In this case, specify that you want to apply the rule to messages with high priority. Then choose the formatting that you want. I chose to list messages with a red background. When new messages arrive with a high priority, they got a red background in the message list.

3
  • I don't think this behavior has changed significantly between Mountain Lion (which you asked about) and Yosemite (which is depicted in my screen shot).
    – samh
    Mar 17 '15 at 17:50
  • It still works the same way on Mavericks 10.9.5
    – Ruskes
    Mar 17 '15 at 18:05
  • This does work for new messages (although why it doesn't work to apply the rule to existing messages, I don't know). I now also see "!!" between the e-mail address and the time in the message, which I did not see before. Just seeing the "!!" by default would be fine, since we want to deploy this solution across our organization with minimum fuss.
    – Michael
    Mar 17 '15 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .