4

Is it possible to disable the trackpad and mouse temporarily while you have an external mouse and keyboard plugged in.

The keys keep getting accidentally hit while I have the mouse and keyboard plugged in.



Edit

Thank you to everyone who answered, because of this I was able to make an applescript to toggle the builtin keyboard on and off:

try
    if (display dialog "Press OK to Enable Keyboard and cancel to disable.") = {button returned:"OK"} then
        do shell script "sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/" with administrator privileges
    end if
on error msg
    do shell script "sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/" with administrator privileges
end try
3

Before doing this.....

WARNING: Before disabling the built-in keyboard, make darn sure you have an external keyboard connected!!

WARNING: Before disabling the built-in trackpad, make sure you have an external mouse connected!

 sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ 

To enable it use external keyboard...

sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ 

Source: http://t3chnot3s.blogspot.com/2013/12/disabling-built-in-keyboard-and.html

However I would recommend a simple and safe and very temporary method is to cut a piece of cardboard and place it on top of the keyboard. It worked for me to prevent my Cat taking over.

  • Is there any way to allow a reboot to effectively reverse this? Also what about the touchpad? I believe because it is a kext it is reversed on reboot. – William Sep 3 '18 at 21:04
  • Also for whatever reason I have to run this twice often oh well. – William Sep 3 '18 at 21:10
3

For the trackpad, there’s a setting for this on 10.7 and later.

System Preferences > Accessibility > Mouse & Trackpad > “Ignore built-in trackpad when mouse or wireless trackpad is present”

As for the keyboard: I haven’t tested this solution for disabling the built-in keyboard and wouldn’t recommend doing it either. Apparently you can unload a kernel extension to disable it completely.

  • I also saw that and didn't suggest it because of it could cause issues. – iProgram Mar 17 '15 at 17:13
1

Cannot find out how to do disable the keyboard but to disable the trackpad do this (for Yosemite)

Go to System Preferences > Accessibility > Mouse & Trackpad and check Ignore built-in trackpad when mouse or wireless trackpad is present

Got this from here.

If you don't want to use the keyboard don't touch it! Will look this up if you still want to know.

  • Thank you for the response I believe the keyboard response is slightly more valuable at this time – William Mar 17 '15 at 17:12
  • Thats ok. How do you accidentally press a key on the keyboard? – iProgram Mar 17 '15 at 17:14
  • my cat sometimes presses the buttons – William Mar 12 '17 at 3:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .