3

I have a Canon MP560 printer/scanner combo, installed and working.

enter image description here

However typically when I turn on the power to the printer and click 'Open Scanner...' I get the following error:

enter image description here

Needless to say the scanner is switched ON and the cable IS connected.

If I reboot my macbook then everything works fine. This is a pain in the neck though. I would like to find a way to get the scanner working without having to reboot.

Full details of my setup:

  • Macbook Air running Mavericks 10.9.5
  • -->connected to CalDigit Thunderbolt dock
  • -->connected via USB and HDMI to Dell monitor
  • -->connected to printer via USB cable

I don't doubt the intermediate elements in the USB chain probably contribute to the problem (same issue with printer directly connected to laptop), however I will note that everything works fine after I reboot my macbook (with printer switched on and connected).

Also:

  • the Mac recognises whether the device is switched on or off when connected
  • can even get ink levels from the printer

...just fails to 'communicate' when trying to scan.

I don't mind if it's a fiddly hack, deleting plist files etc, as long as I don't have to reboot.

It is not the same problem as this How I can get OSX to recognize Canon MP560 Scanner again? since I see the printer and scanner listed as installed.

I have tried 'resetting the printing system' and re-adding the MP560 but it has the same problem.

Attempting to initiate a 'scan to PC' from the scanner's own hardware interface also fails, no error message it just drops back to the home menu screen.

Also Canon MP Navigator software fails to open, with a 'turn on the scanner, connect the USB cable' type of error message.

I would suspect a bad USB cable or hardware problem, except it works every time if I just reboot the Mac.

  • I used to have this problem with an older HP all in one. I used to just yank the USB out of the MacBook then reconnect it (both still powered on). That's quite hackish. – agentroadkill Mar 16 '15 at 21:11
  • Just curious, if you plug the scanner directly into the MBA after it's booted does it recognize it and work okay without having to reboot? – user3439894 Mar 16 '15 at 21:16
  • @user3439894 just tried that, but no it's still the same behaviour even plugged directly to the MBA (haven't rebooted yet) ...it even shows red/green light in the "Printers & Scanners" window when I turn the printer on and off, but if I try to scan it gives the error above – Anentropic Mar 16 '15 at 21:42
  • Just a though, instead of rebooting, what happens if you just logout and login? – user3439894 Mar 16 '15 at 21:43
  • TBH that's just as disruptive (all applications have to quit) so I may as well reboot – Anentropic Mar 16 '15 at 21:44

You must log in to answer this question.

Browse other questions tagged .