When opening a PDF in Yosemite's Preview.app, I can select text using the Text Selection tool from the Markup Toolbar. However, if I don't click directly on the text, a blank text box will appear. For some reason Preview thinks I want to add an annotation everywhere I click even though I have not selected the Text tool.

This is a problem in that it signals an edit to the document, thus changing the modification date and creating an auto-saved version with no meaningful changes.

In previous versions of OS X, I could have solved this problem by using: defaults write com.apple.Preview ApplePersistence -bool no. Yet this does not seem to have an effect in Yosemite.

Any workarounds?

2 Answers 2


I might state the obvious. When it's the first (accidental) edit you make in a document, Undo/Command-Z will not only remove the involuntary text box, but will also revert the document state back to 'unchanged'.

After test addition: You may have to click on a 'safe' zone outside of the text box for Undo to function. Thus creating additional 'edits', you have to Undo-away. My experience is, that after two or three undos the 'edited' tag disappears behind the filename in the window title.

Just tried it and had one additional observation: The only way I found to get the text box to appear was clicking on or near a line in the pdf. That's a feature not a bug: Preview assumes you want to fill out a form.

Hope this helps.



Change your active tool (in the Tools menu) from "Text Selection" to "Rectangle Selection". Once you have done so, clicking or dragging in the PDF will create a (temporary) rectangular selection box. This action isn't treated as an edit, so it won't prompt you to save the document when you close it.

Selecting this tool is not "sticky" across documents, but you can add the "Selection" button to your toolbar to make it easier to activate. The button acts as a toggle.

(Frustratingly, hyperlinks don't work while the selection tool is active. You will need to switch back to text selection to activate them.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .