So I recently bought 4-port Lenovo USB hub with LAN. It came with a driver I needed to install to get the LAN to work. But the documentation said that the USB hub should be unplugged while installing the driver.

Unfortunately - I had the USB hub plugged in while installing the driver. And now the LAN doesn't work.

I've tried installing it on another computer and things work fine. The driver I installed was LAN9500.

Is there anything I can do to make things work?


Uninstall the driver then try again, correctly

This has instructions, but I can't copy/paste them to here.


Cmd/F to search, then search in the 'extra' box inside the page, not Safari's usual search box - for 'uninstall'
It will take you straight to the Mac uninstall page.

I got it… but I really hope you're not doing this on Yosemite… unless you have unsigned kexts switched off

MAC OSX Driver Uninstallation

Note: The device must be safely removed from the computer before beginning the uninstallation.

To begin the uninstallation process, open up a command terminal and enter the removal command sudo rm -rf /System/Library/Extensions/LAN9500.kext/ This causes the device driver to be removed from the operating system.

The final step is to remove the network entry that was created during the installation process. Click the systray network icon (top right corner of the screen) and select “Open Network Preferences...”

  • Thank you for trying to help. I am on Yosemite. Uninstalled the driver. There was nothing listed in the "Network preferences" however. Tried re-installing but didn't work. I am on Yosemite - and don't know what "unsigned kexts switched off" means... – Ankesh Kothari Mar 17 '15 at 7:28
  • See this article; it's about TRIM enabler but the underlying issue is the same - cindori.org/trim-enabler-and-yosemite – Tetsujin Mar 17 '15 at 7:47
  • Thank you again @Tetsujin. So what should I do? Disable kext signing (apple.stackexchange.com/questions/163059/… )... then install the driver... and then re-enable the kext signing? Am I missing some step? – Ankesh Kothari Mar 17 '15 at 10:54
  • To use unsigned kexts you need to disable kext signing & leave it disabled, otherwise it will fail to load that kext again. – Tetsujin Mar 17 '15 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .