1

On my mac I used to be able to send to other mobile devices from my iMessage but now it won't send to phone numbers. It sends to iMessages and emails but not non-iOS phone numbers.

I've tried to delete the iCloud account from my Mac and re-enable it.

I've also done the same on my phone.

Still getting the name highlighted in red

2

Simple first-try fix for a 'red name' above the iMessage pane is click it & reselect the correct contact type/number/email - even if it's the same as the current top line, select it again from lower down the list.

Even if the number cannot accept 'blue' iMessages, it will make the system try again.

Also -
Make sure you have turned on Text Message Forwarding in the Messages settings on your phone. A reset may disable this.

For further options, try https://support.apple.com/en-us/HT204270
or http://www.macrumors.com/2014/11/06/text-messages-phone-calls-on-your-mac/

  • tried before posting...may help someone else though – soulshined Mar 15 '15 at 20:10
  • ah, kk - maybe try the 'switch it off then back on again' approach - sign out & back. (sorry, I always managed to get it going again with that approach so I'm a bit out of ideas) – Tetsujin Mar 15 '15 at 20:12
  • 1
    Google found support.apple.com/en-us/HT204270 and macrumors.com/2014/11/06/text-messages-phone-calls-on-your-mac but it's an off-chance – Tetsujin Mar 15 '15 at 20:14
  • Yeah i tried that too...just found a fix...a novice mistake, when I reset my phone I didn't turn on Text Message Forwarding in the Messages settings on my phone – soulshined Mar 15 '15 at 20:14
  • 1
    If being right is cheap then your worth $0.00 – soulshined Mar 15 '15 at 20:26
2

I just toggle the switch in my iPhone's iMessage settings, iMessage

  • Not sure why this was down-voted. This was the solution for me. If you happen to use multiple SIM cards (e.g. associate multiple phone numbers / SIM cards with your iCloud account - travel out of the country) it is necessary to reassociate your home phone with iCloud when you get home. The easiest wat to do that is go to your iPhone Settings and disable and re-enable Messages. Upon doing so you'll see pop-ups on your Mac about sign-in with your home phone number. Click OK. Upon doing so my messages from Messages on my Mac started working again. – Brandon Coder Jun 4 '17 at 1:39
  • Agreed, my use-case is pretty specific, but I think it highlights the root cause - iCloud is out of sync with your iPhone/Mac. Resetting Messages on your iPhone will get iCloud back in sync with your mobile device and your Mac. – Brandon Coder Jun 4 '17 at 1:50
1

I had a similar issue, though I was no longer able to send to any other device (iMessage or non-Apple). Similar to a couple of others here, it ended up being that Text Message Forwarding was disabled. I don't recall turning it off so either I forgot I did or it was reset during an update.

Select Settings > Messages > Text Message Forwarding. Select your mac or iPad and then enter the numeric code that your phone sends to that device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .