2

I just installed Security Update 2015-002 (Version 1.0) on my MacBook. The latter has a 1.0TB internal hard drive, backed up onto a 2.0TB external USB2.0 3.5 inches hard drive. However, after mentioned update, when I start the computer, I have the following message:

The disk you inserted was not readable by this computer

And I have 3 options:

  • Initialize...
  • Ingore
  • Eject

Clicking on Initialise... brings up Disk Utility, where the external Time Machine disk is now seen as "2 TB External RAID Media" unformatted...

I would like to avoid having to reinitialize it as I have many years of backup history on it. Strange what a "simple" security update can do. I tried First Aid and all of the buttons are greyed out. Impossible to use. I checked via Terminal in /Volumes and, alas, the disk is nowhere to be seen.

Here's what I tried:

  • change the USB cable;
  • tried to list the disk through Terminal: after having switched it on, it takes a good 20 minutes before it starts to spin and then it shows with the command diskutil list;
  • downloaded Kext Utility 2.6.1 and ran the program, but it did not change anything;
  • tried mounting and force mounting, but it did not work...

I found this page (a bit old though) which explains how to force mount a drive and here's what I did:

mkdir /Volumes/Backup
sudo mount -t hfs /dev/disk2 /Volumes/Backup

but it gave me a "mount_hfs: Invalid argument"

So I tried

sudo mount -t lfs /dev/disk2 /Volumes/Backup

and it gave me: "mount: exec /System/Library/Filesystems/lfs.fs/Contents/Resources/mount_lfs for /Volumes/Backup: No such file or directory"

I checked and /Volumes/Backup exists...

I also tried this command (found on this site), but with the same Invalid argument:

sudo mount -t lfs -o rdonly /dev/disk2 /Volumes/Backup/

Finally I tried this (found here):

ps -ax | grep disk2

But it was useless...

6
  • What kind of filesystem/format is on the external drive?
    – nohillside
    Commented Mar 15, 2015 at 18:05
  • taking 20 mins to spin up would really make me worried; I'd be thinking coincidence rather than due to the update
    – Tetsujin
    Commented Mar 15, 2015 at 18:25
  • Agreed, an Apple Security Update has no reason to affect the file structure on an external drive that's used purely for data. It would be different if it had a live operating system on it but as it is this really does look like an unfortunate coincidence. A utility such as DiskWarrior may help (it can work miracles, if not actually achieve the impossible) but after your experience I wouldn't trust the disk again for long-term storage. 20 minutes to spin up should set alarm bells ringing, and if DW couldn't restore its file system and return it to a usable state I'd look at retiring the disk. Commented Mar 15, 2015 at 19:11
  • Similar problems after security update 2015-002, immediately after the update all 8 of my external disks mount but get ejected improperly right away and are just stuck in an infinite loop of mounting and ejecting. Must be the update causing this :/ I'm using a MacBook Pro 3.1 17"
    – user119139
    Commented Mar 22, 2015 at 13:51
  • Resetting SMC and PRAM seems to have fixed my issue.
    – user119139
    Commented Mar 22, 2015 at 14:12

0

You must log in to answer this question.

Browse other questions tagged .