I have two Macs, a Lion and a Yosemite. I have several accounts on each one, both user and admin. I activated file sharing on both Macs and selected AFP. I can connect from any account on one Mac to any account on the other one Mac as expected, with one exception.

"As expected" means: Select go->"connect to server" in the Finder menu, then enter one of the users names on the other Mac and its password when prompted, then choose which of the folders on the other Mac to mount.

The exception is that in one of the accounts the Yosemite Mac ("xyz" - unix name) I do not get the "connect as" prompt. It connects directly as the user "xyz" (same name) on the Lion Mac, without giving me a choice or asking for a password. It only asks me which folder I want to mount.

I signed out of iCloud in account xyz on the Lion Mac, changed the password, and deleted the keychain, restarted, etc. Still, no "connect as" prompt.

Now, if I sign out of iCloud in the account xyz on the Yosemite Mac, too, I do get the expected "connect as" prompt. Sign in again, no prompt.

Thus there must a permission buried somewhere on the Lion Mac that grants access to the incoming connections via my Apple ID. However, a brute force search (recursive grep) revealed no trace of my Apple ID. Where can such a permission be buried and how can I reset it?

I tried to replicate this (unexpected) behavior in other accounts, using new Apple IDs, but I was not successful. I always got the expected user name/password prompt.


Could be a number of things. A few that come to mind:

If you're using Directory Services (e.g. Open Directory/Active Directory), the device could be authenticating using Single Sign-On (SSO). This would most likely be if you setup Server.app or if it is a device from your work/office.

Potentially, you could be connecting as Guest.

To authenticate as a different user: afp://<username>@server_address

  • This partially solved my problem. "To authenticate as a different user: afp://<username>@server_address". I am still puzzled because the behavior looks indeed like you describe (SSO), but do not remember setting it up. – John H Mar 17 '15 at 12:28
  • Actually, I used to have iCloud on the Lion computer. Only recently I signed out, and also deleted the keychain. The account xyz on the Yosemite computer has the same iCloud account enabled. Could the Lion computer still authenticate users via Apple ID despite being off iCloud and no iCloud password in the keychain? – John H Mar 17 '15 at 12:42
  • Wondering the same when connecting from Mojave to High Sierry: Connects without prompting and I have explicitly denied read only to anyone. I also suspect that Apple-ID is the "culprit" as I use the same on both Machines – Paschi Feb 13 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .