1

The B&O H8s work great some of the time wirelessly (iPhone) and wired, but not with MacBook Pro 15 early 2011 (Airport/Bluetooth card upgraded to BT4.0). However, sometimes, they will start to skip and drop in and out (as if I were plugging and unplugging an audio cable). The speed of the audio will increase after it skips to "catch up". None of the online fixes seem to help this out. Can't get the RSSI above -60 dBm. Appreciate any help at all. Thanks.

1

They are working perfect with OS X Yosemite 10.10.2. After upgrading to 10.10.3 (beta or final) the problem that you described appear. The headphones are working perfect first time after adding to bluetooth list, but is not a solution to delete and add again.

Bang & Olufsen post this to their website:

Can I connect my BeoPlay H8 headphones with my MAC/PC using Bluetooth?

In most cases BeoPlay H8 is able to connect to a PC/MAC with Bluetooth 4.0 and a A2DP Bluetooth profile, provided that the hardware and drivers of the computer are also compatible. However, the computer protocols in the market are inconsistent and we cannot guarantee that BeoPlay H8 is able to connect using Bluetooth to all PC/MACs.

  • Thank you for your observations. For me, Yosemite 10.10.2 was a huge problem for my MBP. Upgraded to 10.10.3 just now and it APPEARS to be marginally better inasmuch as the raw RSSI values seem to be in the -60s rather than quickly jumping to -70s or lower. That could be temporary due to a lack of interference at this early hour on a Saturday. I'll update if I find a definite improvement in the amount of dropouts correlative to the data rate (bytes/sec) drop. Still very fortunate that my for the time being my iPhone seems to work well with very few anomalies. – Darren Stevens Apr 11 '15 at 11:39
  • Sadly, the upgrade to OS X 10.10.3 produces absolutely no change whatsoever. C'mon folks, there's got to be someone out there who knows the answer to this problem. Apple and MS are major computing device companies. How arrogant of B&O to make products that are not universally compatible, much less make that stupid statement in a FAQ instead of a clear and conspicuous caveat in its tech specs for everyone to see upfront without having to hunt for it. – Darren Stevens Apr 12 '15 at 11:38
1

I had some success by installing XCode, then installing the Hardware IO extensions to Xcode (I seem to recall that was in Xcode..open developer tool...more tools).

Once installed, you can run bluetooth explorer, which has two useful tools:

  1. Tools..audio options
  2. Tools..audio graphs

Between these you get some specific settings you can adjust, and more information about what is going on.

In my case I increased the minimum and maximum bitpool, and pushed the buffered packets out to 1000. This seemed to increase the quality setting that bluetooth uses, and to allow it to be much more tolerant of dropouts.

Ultimately my problem was also partly a line of sight issue, and also probably being close to both the microwave and the wifi router, which would cause interference. But pushing up the buffer size gave a bit more tolerance to that interference.

The only thing to watch out for is that I'm having serious issues with my bluetooth not reconnecting to my bluetooth speaker...I don't believe it's due to this setting change, but arguably it could be.

-1

Try to edit advanced settings to macbook bluetooth with "bluetooth explorer" HardwareIOTools_Xcode. I just manage to improve my bluetooth connection.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .