5

I just purchased a new MacBook Pro and migrated everything over from the old one. I had imagined that it was the old one that was preventing me from being able use Font Book (Font Book.app); it’s not that.

When I attempt to open it on the new machine, looks like it is going to work for about five seconds, then becomes completely non–responsive, including the spinning wait cursor, until I use Force Quit.

So far I have tried deleting

  1. ~/Library/Preferences/com.apple.FontBook.plist,
  2. ~/Library/Preferences/Saved Application State/com.apple.FontBook.savedState, and
  3. ~/Library/Fonts,

and then rebooting, but to no avail.

  • Do you have a lot of non-apple fonts added to your machine? If so, try temporarily removing them. – Tom Gewecke Mar 14 '15 at 14:35
  • I’m not sure which one’s were which—I used to be kinda hasty about adding new ones every time I saw mojibake in Wikipedia entries. Based on their Last Modified dates, I’m assuming it’s probably only those in ~/Library/Fonts (but not those in /Library/Fonts or in /System/Library/Fonts, right? Can I simply delete ~/Library/Fonts temporarily? Sounds risky. – Lucas Mar 14 '15 at 14:47
  • Just move everything in ~/Library/Fonts to a folder on your desktop and restart and see if fontbook will work right – Tom Gewecke Mar 14 '15 at 15:55
  • I tried deleting the fonts in ~/Library/Fonts and Font Book still opens, then hangs until I use Force Quit. The question is edited accordingly. – Lucas Mar 15 '15 at 21:18
  • . . . and for what it’s worth, during the seconds right after I open it, but before the hang begins, the pane on the left briefly shows four items before quickly hiding the last one (it’s so fast that I had to try a couple times before I could make out what it said). There’s “All Fonts” then a subheading “Smart Collection” with one entry (“English”). The item that comes and goes is another subheading called “Collections”; it is empty. – Lucas Mar 19 '15 at 21:15
8

Make a backup of /Users/YOUR_USERNAME/Library/FontCollections, and then delete that folder. Most likely, it's a corrupt font collection. Then, recreate the folder, and add each one back if you really want to investigate.

Otherwise, just delete the collections and start over.

| improve this answer | |
  • 1
    It worked! It was as simple as removing ~/Library/FontCollections. Thank you :-) – Lucas May 14 '15 at 1:29
  • Happy to help. Glad you got it sorted. – Kevin Suttle May 14 '15 at 4:54
2

After upgrading to El Capitan Font Book crashed - EVERY time I launched it. Though I couldn't delete the Font Collections folder, I could remove all of the items in it. AND IT WORKED! Font Book is now as it should be. Oh Happy Day!

| improve this answer | |
2

A variation of suggestions from Alistair and Kevin and the Lucas, the OP, worked for me.

This is exactly the problem I was having. From Lucas: Before the hang begins, the pane on the left briefly shows four items ... “All Fonts” then a subheading “Smart Collection.”

I force-quite Font Book, went to the FontCollections folder (Finder Go Menu, pasted ~/Library/FontCollections).

Sorting by date added, there were some from the day of the crash. I threw those four font collection into the trash, and was able to reboot Font Book without a hitch.

To be safe I should probably trash them all, but for a quick fix this got me back in business.

| improve this answer | |
  • Font Book crashed on me while I was creating a new Smart Collection, and since then it would crash on launch. I could just delete the collection that caused the original crash and everything was OK again. – hmijail mourns resignees Mar 18 '16 at 22:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .