1

As a matter of fact, my 1 TB External hard disk has three partition: "MAC OS", "NTFS" and "FAT32". All of the partitions worked very well in the past.

However, I just discovered that my Mac OS Extended (HFS+) formatted "MAC OS" partition could not be mounted, although the other two partitions were seemingly fine. I tried to repair the partition with Disk Utility but it failed. I have no idea why this had happened to my hard disk, since I have not done anything disruptive to my hard disk and my MAC OS partition.

I have only done two things before I discovered that my MAC OS partition was no longer working:

  • I installed the Apple Security Update 2015-002 when my hard disk was plugged into my Macbook air.
  • I tried to move some files from my "NTFS" partition to another external hard disk. But it failed because of unknown reason.

This is what I got when I did the "diskutill info" on Terminal:

enter image description here This is what I got when I tried to repair my partition:

enter image description here

How do I solve the problem and recover my "MAC OS" partition and get my data back?

  • 1
    Looks like the kind of fail I'd hope to have a backup for… or at least have Disk Warrior to have a go. Failing that, Data Rescue 4 – Tetsujin Mar 13 '15 at 23:28
1

Got it back when giving even the hfs+ partition a drive letter in Windows drive-management, did a chkdsk there. (It was an external usb-drive 3Tb)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .