2

Since I installed a new access point, I have troubles with only one Mac to access the printer and NAS on my network. Every other computer (Mac or PC) or device (Android or iOS) is working perfectly.

I make a quick sketch on Visio to illustrate how it looks : network

To resume the situation, we have :

  • One router which has a wifi network and DHCP.
  • One printer which is wired to the router.
  • One NAS which is also wired to the router.
  • One Access Point (new one) which is wired to the router. It has no DHCP, and the same SSID + Password as the router's wifi.
  • Three Macbook Air that are using the wifi (A, B and C).

The Macbook Air B and C are connected to the Access Point and are working perfectly. But the Macbook Air A, when it's connected to the AP (Conn 1), it cannot see the printer nor the NAS, but it can access internet and access to the router administration page. Other computers can be randomly seen (I believe that the devices on the AP are seen by A).

But when the Macbook Air A is connected to the router's wifi (Conn 2), everything works perfectly.

I tried to troubleshoot the problem on the Mac's side but also on the AP side. Here's what I checked and tried :

  • Upgrade or downgrade the AP's firmware -> Didn't change anything.
  • Try different configurations on the AP -> Didn't change anything.
  • Put a static IP -> Didn't change anything.
  • Clear the ARP table -> Didn't change anything.
  • Ping the printer or NAS IP -> No response.
  • Scan the entire network -> No printer nor NAS seen.
  • Is the Mac network configuration correct ? -> Yes, 100% sure.
  • Is the firewall enabled or misconfigured ? -> Nope, disabled.
  • Is the Mac up-to-date ? -> Yes, every updates have been done.

I believe that the problem is coming from the Mac and not the network as the other Macbook Airs are working correctly. But I'm not a Mac expert and I don't really know where else to look. Any advice, idea or solution would be greatly appreciated!

  • 2
    Welcome to Ask Different! Nicely structured question. I don't know the answer, but wish you luck – Tetsujin Mar 13 '15 at 15:18
  • Did you try the direct connect (manually), also for test remove the Conn 2 from profile. – Ruskes Mar 13 '15 at 16:51
  • @Buscar웃 Yes, I tried direct connect but it cannot see other computers. I also removed all connections (Conn 2) and added them again, same result. – Keraf Mar 17 '15 at 12:34

You must log in to answer this question.

Browse other questions tagged .