4

For a few weeks, I've noticed that my keyboard layout keeps reverting to U.S. each time I reboot. To be precise: each time I reboot, my System Preferences -> Keyboard -> Input Sources window looks like this:

enter image description here

I keep changing it to this (but it doesn't stick around for long):

enter image description here

NB: MathUnicode is a .keylayout file of my own making, which I've used for several years now, without any problems.

I'm running OS X Yosemite (10.10.1) on a MacBook Pro (13-inch, Early 2011).

Does anybody know how I can stop it reverting to the U.S. keyboard layout?

  • remove it from keyboard preferences! what does it do than ? – Ruskes Mar 16 '15 at 19:33
  • huh... it doesn't look like any of the keys change between the two screenshots (not that this isn't a problem worth solving, I just noticed that) – dwightk Mar 18 '15 at 16:05
2
+50
  1. Select Keyboard you want.

  2. Shut down your Mac.

  3. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously Turn on the computer.

  4. Press and hold the Command-Option-P-R keys before the gray screen appears. Hold the keys down until the computer restarts and you hear the startup sound for the second time.

  5. Release the keys.

After resetting NVRAM or PRAM, you may need to reconfigure your settings for speaker volume, screen resolution, startup disk selection, and time zone information.

1

If the prior recommendation did not work, consider the solution given by Brunni on https://superuser.com/questions/99172/how-to-stop-os-x-from-switching-input-method-keyboard-layout-automatically: You should put your custom KeyboardLayouts not in the User, but in the System Library folder.

You must log in to answer this question.

protected by bmike Sep 3 '18 at 16:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .