0

I have noticed that a couple of shortcut keys have stopped working. Thinking it could be another app using the shortcuts I've been into keyboard settings and restored all the default keys. This has not affected the problem.

The issue appears to be happening across different apps (I'm testing in Finder, Safari and my text editor).

Here are some examples: ⌘S for saving doesn't work, but ⇧⌘S for save all does work. ⌘N for a new window/file (text editor) doesn't work, but ⇧⌘N for new file(Finder)/new private window(Safari)/new window(text editor) does work.

Particularly ⌘S I use on a regular basis. I tried to add it again:

Keyboard preferences > Shortcuts > App Shortcuts > Add

and ⌘S is still not working.

I'm working on a MacBook Pro with an external keyboard. The situation is the same working with the external keyboard connected or directly with the MacBook's own keys.

How can I get the shortcut keys' functionality back?

OS version 10.10.2 (14C1510)

--update--

I have also tried swapping the modifier keys over, I set to and vice versa - didn't fix the problem.

0

In trying to debug this issue I assumed that some other program had taken control of these keys. After force-quitting all open applications it did not help.

I then went to Activity Monitor and noticed one of my task bar apps was non-responsive. The app happened to be a clipboard manager (PasteBox). After quitting this app, all lost functionality has returned.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .