1

I've recently went to an Apple store and the guy reset all my settings. Lately, whenever I text people with iPhones, they tell me that I don't text from my number anymore, but from my Apple ID email. I tried going into Settings and changing some things, and texting some of my friends to see if it's changed but they keep saying I'm still texting from my email. How do I reverse this or text from my regular number?

marked as duplicate by bmike Mar 12 '15 at 21:21

This question was marked as an exact duplicate of an existing question.

  • Also see apple.stackexchange.com/questions/37884 If none of the linked questions is your situation, just edit your question to make this clear how your setup differs than the setup in the other questions. (or perhaps how you're not clear what the linked answers instruct you to do to solve the caller ID dilemma you are facing). Please disregard the "ask a new question" advice above - that's for others and you'll want to edit this if your situation isn't fully addressed. – bmike Mar 12 '15 at 21:20
1

Under your Message settings in iOS, there is an option to select which address or phone number new conversations will originate from.

Settings > Messages > Send & Receive > Start new conversations from:

  • Additionally, to solve the problem with those who already have threads in messages, deselect all emails addresses from the list of "Send & Receive at". – bassplayer7 Mar 12 '15 at 19:16

Not the answer you're looking for? Browse other questions tagged .