3

I've installed Windows 8.1 with the Boot Camp Assistant on a solid state drive with a CoreStorage volume. Booted to Windows I can't see the files on my Mac volume anymore.

I'm confused since this is the same setup steps I used to install Boot Camp on an iMac previously and that Windows install has no problems to see the Mac volume and read the Mac files.

How do I regain at least read-only access to my Mac files on the SSD MacBook Pro?

Output of diskutil and gpt:

 -bash-3.2# diskutil list  
/dev/disk0  
 #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:      GUID_partition_scheme                        *500.3 GB   disk0  
   1:                        EFI EFI                     209.7 MB   disk0s1  
   2:          Apple_CoreStorage                         234.4 GB   disk0s2  
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3  
   4:       Microsoft Basic Data JZ81p64                 265.0 GB   disk0s4  
/dev/disk1  
   #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:     Apple_partition_scheme                        *1.3 GB     disk1  
   1:        Apple_partition_map                         30.7 KB    disk1s1  
   2:                  Apple_HFS OS X Base System        1.3 GB     disk1s2  
/dev/disk2  
   #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:                  Apple_HFS JZYsmyt                *234.0 GB   disk2  
                                 Logical Volume on disk0s2  
                                 E21EC611-3794-4B0D-BFDB-299510FCDFAB  
                                 Unencrypted  
/dev/disk3  
...


-bash-3.2# gpt -r -vv show /dev/disk0  
gpt show: /dev/disk0: mediasize=500277790720; sectorsize=512; blocks=977105060  
gpt show: /dev/disk0: PMBR at sector 0  
gpt show: /dev/disk0: Pri GPT at sector 1  
gpt show: /dev/disk0: Sec GPT at sector 977105059  
          start       size  index  contents  
          0          1         PMBR  
          1          1         Pri GPT header  
          2         32         Pri GPT table  
         34          6           
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B  
     409640  457756312      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC  
  458165952    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC  
  459435488        544           
  459436032  517668864      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7  
  977104896        131           
  977105027         32         Sec GPT table  
  977105059          1         Sec GPT header  
  • 1
    @klanomath Many thanks for your edit, how you do that, does it require any html coding knowledge ? By the way, I do apologize for my poor English which is not my mother tongue, hence my slow writing / typing. – dzu Mar 13 '15 at 10:26
  • Here are two links how to edit/format the text: editing help and tags allowed – klanomath Mar 13 '15 at 10:29
  • @klanomath Let's keep this one open for now - it's a tricky subject and we might need several posts. Some could have the basic details and some that walk new terminal users though the steps and dangers more explicitly. Closing it wouldn't be the worst, though - especially if there are a handful of other dupes already asked on the site. – bmike Mar 13 '15 at 11:20
  • @bmike NP ;-) You added a bounty to this somehow related question. Is it ok to add a second (streamlined) answer or should I modify my already published answer? – klanomath Mar 13 '15 at 11:56
  • @klanomath Totally your call. When I end up with a really long explanation I like to edit it to put the short, sweet answer at the top. Then add ---- and then dive into the why / how / explanation part. It's really what you like. I'll probably plop a second bounty on another question once I figure out which one. Feel free to ping me there if it's not here. – bmike Mar 13 '15 at 11:58
3

Instead of a default/classical Mac volume like your iMac, your MacBook Pro contains a CoreStorage volume.

Booted to Windows, CoreStorage volumes cannot be mounted and consequently the contained files can't be read - until now.

You would need to revert the CoreStorage volume wrapper that contains HFS+ back to a straight HFS+ volume to regain read-only access.

I'm surprised Apple doesn't have KB article on this, but look here:

Basically, boot to Recovery HD (or another external Mac volume) and then issue the command:

diskutil cs revert E21EC611-3794-4B0D-BFDB-299510FCDFAB

That would take partition 2 on disk0 (the Core Storage part) and revert it to the HFS+ or classic disk layout that Windows knows how to read.

  • Forgive the large edit - I'm really getting a lot of great information from your posts klanomoath - thanks so much. – bmike Mar 13 '15 at 11:17
  • @klanomath Thanks for your time spent on answering my newbie-question. I will make a disk image or a backup of my Apple HFS (JZYsmyt) first, then try the command diskutil cs revert xxxxxxxx By the way, have you tried executing such command yourself ? Will that command erase all inside data then reformat the disk, like DOS / Windows' format command ? Will that command jeopardize the standard structure of the SSD ? I am afraid structurally the HFS volume MUST STAY INSIDE the Apple CoreStorage ... – dzu Mar 13 '15 at 18:32
  • @dzu The command is non-destructive - it shouldn't delete anything. I have executed it several times already and it worked without any problem. You are always advised to backup your main volume though. – klanomath Mar 13 '15 at 18:36
  • @klanomath Many thanks, now Windows 8.1 lets me see the files on my Yosemite volume. However, when booting from Recovery HD, using *diskutil cs list", it stills list lot of other disks from disk2 to disk14 as I copy and paste above, what are they and may I delete them, and how to delete them. – dzu Apr 4 '15 at 10:45
  • @dzu Don't delete them. They are all part of the Base System and mounted temporarily while booted to Recovery Mode/Internet Recovery Mode – klanomath Apr 4 '15 at 10:49
0

Do you mean you can't boot into Mac OS X anymore, or you can't see the OS X partition when you boot into Windows? If it's the latter, it's because the Macintosh file system is not readable by Microsoft Windows. You can go into Computer Management > Disk Management, it would show the partition, however it's not browsable by Windows. There is some third party software out there which will let you mount it, however it's too risky. You could very easily delete a file and OS X would no longer boot.

  • @PatrickMy Mac Yosemite is working normally. Only when I log in Windows 8.1 (via Boot Camp) : – dzu Mar 12 '15 at 17:52
  • Right, so then we're talking about the second half of my original answer. Think of it like taking a Mac-formatted drive and plugging it into a Windows computer. Windows can't read or write hard disks which are formatted for Macintosh. As I stated above, leave it alone. It's like this on purpose. – Patrick McMahon Mar 12 '15 at 17:55
  • My Mac Yosemite is working normally. Only when I log in Windows 8.1 (via Boot Camp), in Windows Explorer : - My iMac - using regular IDE Seagate hard disk - can see, browse all files in Mac OS X partition. - My MacBook Pro (Retina 15-inch, Mid 2014) using SSD can't. – dzu Mar 12 '15 at 18:07
  • I do apologize for my poor English which is not my mother tongue, hence my slow writing / typing – dzu Mar 13 '15 at 10:15
0

I've been trawling the lists on this topic. If you have a fresh install of Yosemite (not upgrade, clean install), you get a Core storage volume which is marked as NOT revertible. Hence the advice to use:

diskutil cs revert <G/UUID>

does NOT work.

I've tried the following:

  • boot from recovery, can't convert the disk, nor delete the disk
  • boot from external install disk or USB installer, cannot convert/remove the primary storage
  • A post I saw, saying "Turn on file vault, then after its finished, turn it off." (total elapsed time on my 1tb disk; 26 hours) Disk is still NOT 'Revertible'

I've been trying to resolve this issue for 2 days now. After reading through hours of posts, the only way to revert a Core Storage volume to a HFS volume is to...

  • start with a HFS volume in the first place
  • upgrade to Yosemite
  • revert the disk

Otherwise there is nothing to revert to.

My current plan is to install Lion (it's the only installer I burned to disk in the last few years). Then install Yosemite, then revert the disk to HFS+

My logic is sound, but with wiping my disk (again), and the inherent loss of internet history, its unlikely I'll find my post here to let you know how I got on.

Your milage may vary.

0

as mentioned by klanomath, the reason you cannot see you Mac HD from bootcamp on your SSD MacBook Pro is because on that machine, the Mac HD is a CoreStorage device.

If you have been able to revert it to HFS+ as described then ok, If you can't revert it as per my post earlier, then you are stuck with it. You'll need to use a USB stick to transfer.

I've done extensive research on this. I have not been able to find any windows drivers that allow you to read a Mac CoreStorage device from Bootcamp.

In anyone has found a way to do this, please post.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .