3

Since upgrading from Mountain-Lion to Yosemite, my MacBookPro5,5 (13", 2.26GHz C2D, GeForce 9400m) is (almost always) showing bad performance while working with native windows like Finder, System Preferences and Application Switcher. Even simple things like scrolling a folder in Finder spikes the CPU up. 'WindowServer' process shows high cpu usage (above 50%) while doing these and always tops the 'Total cpu usage' in Activity Monitor.

Updating to 10.10.2, erasing the disk and making a fresh install, following any recommendations about transparency/display/... settings I can found on the web (summarized mostly in WindowServer high CPU on Yosemite and its follow ups), even applying combinations of them did not have any significant effect. This is a clean install (not an update) and I only have Google Chrome as an external/installed app. I don't have an external monitor, although I even tried the recommendations including one...

I have installed Mavericks and this problem is not present now, but I will have to upgrade to Yosemite soon... Has anyone found a working solution yet?

  • Have you tried this? apple.stackexchange.com/questions/154689/… – pilsetnieks Apr 27 '15 at 14:23
  • Also, a followup question, are you using an external display? Also, when you're having these slowdowns, do you have Chrome open, or any app that embeds the Chrome engine (e.g. Spotify)? It seems that a running theme of this windowserver problem involves Chrome and/or external displays. – pilsetnieks Apr 27 '15 at 14:29
  • @pilsetnieks see the last edit. – user3648895 Apr 30 '15 at 13:56

You must log in to answer this question.

Browse other questions tagged .