0

About a couple of weeks ago, I tried turning on my Macbook Pro and it seemed completely dead. I plugged in the power cable but it still didn't work. Since it's not under warranty anymore, I opened up the back, disconnected the battery, plugged the power cable in and this time it worked. After booting it up I plugged in the battery and it started charging, I can use my Macbook without the cable fine, but other issues occured.

Battery status:

enter image description here

Here are my MB specs:

enter image description here

  • I can't power on with the power button so I have to either connect the power cable or sometimes disconnect the battery (I think this is based on how much the battery is charged)
  • Camera doesn't work anymore (no device connected)
  • Power button doesn't work at all

I can't reset SMC (I can't boot properly and nothing happens after pressing the keys). I've tried all the things listed under this Apple's Guide

I've tried updating the SMC firmware, but it didn't help.

Isn't it possible to reset the SMC (which I think is the cause of this) through the terminal or by disconnecting the internal battery(logics board?) or something similar?

  • nope, not by Terminal. Reduce your brightness to minimum then reset SMC, if it worked you will know. Also tell us the status of your battery. – Ruskes Mar 11 '15 at 16:58
  • Dimming the brightness didn't work. I've added the power status to my question. – Ignas Mar 11 '15 at 18:16
  • Thanks, so the battery is reporting cycles count of 1132 which is higher than specified by apple, but it reports condition as normal ? (it should say replace battery!), this could be caused by not functioning SMC, so lets find a way to properly reset it for your model. – Ruskes Mar 11 '15 at 18:25
  • Yeah, i've run the hardware diagnostics and it didn't find any problems with the hardware. So maybe I do need to replace the battery but it doesn't explain the other issues. What are other ways to reset the SMC? – Ignas Mar 11 '15 at 18:34
  • It would explain your power button not working support.apple.com/en-us/HT201295 – Ruskes Mar 11 '15 at 18:38

You must log in to answer this question.

Browse other questions tagged .