32

I've been encountering an extremely annoying problem since I upgraded to Yosemite. FCPX (but I've been having reports of this problem on other computers with finder.app and safari.app) sometimes will crash on exit (with no detectable log trace) and its icon will remain in the dock with the usual "this application is not responding" menu warning. Force quit won't work Rebooting can only be done the hard way because the stuck app is preventing a soft one yet no single process regarding FCPX is listed when in the activity monitor nor there is one in psaux. No zombie processes to be found; computer performance is fine. If I open an FCPX library, I'll get a dialog stating that "The application "Final Cut Pro" is not open anymore", which is quite irritating q:

I'm on a MBP Retina early 2013 15'

Does anybody have the slightest clue what's going on here? It happens often enough that hard resetting every time is not a viable long term solution.

Also, I'd be extremely useful to know what to do when this happens on other machines with other apps (:

I hope someone can help

Thanks Marco

  • Could you still publish the Console log around the time stamp of interest so to see what is going on. Also, if you run "ps -A > process.txt" outputs file to your home directory, that can be used for your records to see what processes are active (before crash). – Ruskes Mar 11 '15 at 16:12
  • Chrome does this very occasionally for me. No more then once every two weeks if I were to take a guess. – bassplayer7 Mar 11 '15 at 21:18
  • I have faced very similar problems. Ended up downgrading to Mavericks which was quite straight forward and I can't really say that I regret that step at all. Won't use Yosemite anymore anytime soon. – beta Mar 13 '15 at 8:44
  • thanks for the kind answers; unfortunately the logs are always totally silent around time of crash, and as I stated before ps is not useful either because there is not one single process linked to FCPX after it crashed. I will however post both logs and p s output when I encounter the problem again. Also to be noted, last day I force ejected one external drive and that itself for the first time in months released my zombie FCPX. Is this useful? Thanks Marco – Marco Carandente Mar 16 '15 at 11:44
45

(I know this is an old question but I think this might help somebody)

I had the same problem with NetBeans and this is what worked for me:

sudo killall launchservicesd
sudo killall Dock

I hope this helps.

  • Could someone explain what launchservicesd does ? – Matthieu Riegler May 3 '16 at 21:20
  • @MatthieuRiegler The manpage isn't very helpful: Description: launchservicesd is used internally by MacOS X to track and coordinate information about the running applications on the system. Did you find more complete and useful information? – jsejcksn May 27 '16 at 5:15
  • 1
    Did you ever work out what was making NB do this? I have the same problem and I can't work out how to fix it. Following your procedure allows me to reboot but doesn't fix the underlying issue. – sprinter Jun 3 '16 at 4:57
  • No, I haven't had the error again for a while. Are you using the latest NB? – loco.loop Jun 28 '16 at 13:25
  • Works always for misbehaving firefox on el-capitan. – akhan Jan 4 '17 at 20:26
5

I'm running OS X 10.11 "El Capitan" on my Macbook Pro, and I'm experiencing this issue with Mozilla Firefox. Unfortunately, in my case the commands sudo killall launchservicesd and sudo killall Dock aren't working this problem out: after I do this, I still can't e.g. reboot the operating system.

I found that the following command works on Macs:

sudo shutdown -r now

If your user account has administrative privileges on OS X, running the above command on Terminal will force OS X to reboot. Unfortunately, this is not a solution for the issue, but as a "last resource workaround" it works like a charm.

2

This is based on loco.loop's answer. This was happening to me very frequently with Synergy app. I've now turned this into a bash script.

sudo echo "#!/bin/bash
sudo killall launchservicesd
sudo killall Dock" > /usr/local/bin/fixDock && sudo chmod +x  
/usr/local/bin/fixDock

Now I just type fixDock in my terminal. :)

1

Open Activity Monitor, search for the process launchservicesd. Highlight the process and force quit the process. It will take a while for the laptop to respond but the offending zombie app will also quit. Works well for latest versions of Firefox and Mac OS X El Capitan 10.11.3.

0

I had problems with the other solutions as my computer was stuck in "attempting to shutdown" mode. In other words, I couldn't open a terminal window or anything else as the OS was trying to shut down all applications. But it just hung, waiting for this errant process to die.

I eventually did a HARD POWERDOWN. That is, I held the power button for four seconds until the power went off.

Wait ten seconds, and power back up. Everything works fine. Hope this helps.

0

I've had a similar problem after force quitting an application (has happened with Firefox, SQL Developer, Eclipse) on Yosemite. I have found a solution that does not require an actual restart:

  1. Click on the Apple icon in the top-left, click on Restart, and click Restart on the dialog that pops up. Seemingly, nothing will happen
  2. Repeat this process 10 or so times. You may need to close some apps when prompted so they don't interrupt the restart process. Try to avoid closing anything that will inconvenience you too much.
  3. As you're doing this, periodically check if the app is still considered "running" (ie. hold-click on the icon - if it says "Force Quit" it hasn't worked yet).
  4. Eventually the restart task will terminate the stuck app. When you notice this, stop telling it to restart.

This is the only solution I've found. It's more art than science, but it looks like within 60 seconds or so the restart task gets rid of the broken app and everything is fine. For me, this was much more convenient than actually restarting the computer - some apps don't restore very well. I tried the same approach with Force Quit (ie. repeatedly Force Quitting) and got no results.

Every time this has happened to me I have been able to successfully bail out of the restart (usually by refusing to close apps that are blocking the restart) after it's closed the broken app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .