I have a 5th generation, 16GB iPod Touch that has iOS 8.1.0. I have a fairly recent version of iTunes.

I recently deleted over 1000 photos off my iPod and also deleted them out of the Recently Deleted section. (Note: I also have the photo streaming thing turned off.) When I plug my iPod into my computer, it still says that I have over 2000 pictures that are taking up 4GB of space on my iPod!

  • Try turning the device off and restarting it.
    – Tyson
    Commented Mar 11, 2015 at 2:58
  • My iPhone 6 had a similar issue: iCloud backups stopped working claiming I needed another 20GB of space because my photo library was almost 26GB. iTunes said I had over 4500 pictures on my phone but the Photos app only showed about 2500, including photo streams, bursts, etc. I started deleting hundreds of videos and pictures and clearing the "Recently Deleted" folder but it wasn't giving back much space. I set the clock back a year and suddenly Recently "Deleted" showed almost 600 items. Once I erased those I got over 10GB back and iTunes but iTunes said I still had 3700 pictures and iCloud st
    – Jason S
    Commented Jun 1, 2015 at 21:50

3 Answers 3


I have found the solution to the problem.

Quoting the solution from txforever from Apple forum.

Im not sure why is this happening, but i just know how to get rid of the prob.

It has something to do with the Recently Deleted folder in the iPhone.

You need to change the date of the phone to earlier mayb a year earlier as in 2014. Then go into your Photos>Recently Deleted folders to clear all the photo manually.

Note, when you go into photo, the Recently Folder might show 0, but if you go into it, there is actually photo in it.

  • 1
    If quoting from a web page please give urge URL as well as the quote
    – mmmmmm
    Commented Mar 15, 2015 at 13:04

HAHA!! I figured it out! You have an album titled "Recently Deleted." Once you delete a photo or video, it is saved here for up to 40 days (usually 30). On your device, go to Photos--->Albums--->Recently Deleted. Then, tap "select," select each photo (annoying...), tap "Delete" and confirm. Done! http://help.apple.com/icloud/?lang=en-us#/mm6aa648d5aa


I had the same problem, but my cause was a little different. Sometimes 3rd party apps store photos on the phone without your knowledge. My culprit was the flickr app. Check the photo settings on your apps. For example, for Flickr: Settings / Privacy / Photos / Flickr

So, I turned it off and back on and the problem was instantly fixed. Yeah!

Apple, a little more detail on what is taking up space would help a lot!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .