I replaced my CD drive with a Western Digital 750GB hard drive using the iFixit guide.

My Mac for some reason throws error on any interaction with the hard drive, for example on disk utility when I tried to create 1 partition of FAT:

disk utility failure on 1 partition

When I try to setup BootCamp I get this error:

bootcamp error

I have successfully managed to erase and format the hard drive while booting up to GParted, but I want to install windows on it.

Do you have any suggestions? Ideas?

  • 1
    Since you formatted it with GParted have you tried installing Windows to that drive while booting the Mac from the Windows installation media? Commented Mar 10, 2015 at 18:27
  • I tried, but I checked 3 installation media and they all stuck at the phase of "Windows is loading files..", so I am trying to do this using bootcamp.
    – Yosi
    Commented Mar 10, 2015 at 18:35
  • If there is nothing else on the HDD then you shouldn't need to use Boot Camp Assistant for other then to create the USB installation media and download the Windows Support Software, although that can be downloaded separately directly from Apple. In the past, although not lately, I've install Windows without the use of the Boot Camp Assistant in any capacity. How was the USB installer created and from what source disc or ISO image? Since Disk Utility had an issue it's not a good sign even though GParted worked. You may need to resolve that issue first and before installing Windows. Commented Mar 10, 2015 at 18:47
  • 1
    From ISO using Rufus.
    – Yosi
    Commented Mar 10, 2015 at 18:51
  • 1
    Did you verify the checksum for the ISO Image and from where was it acquired? Commented Mar 10, 2015 at 18:54

3 Answers 3


I recently ran into this issue as well. I originally suspected a damaged SATA cable, but swapping the SSD into the optical drive bay and the HD into the primary hard drive bay solved the issue for me.

  • Hi Chris, if this an hardware problem - how I managed to install ubuntu on it and it works fine?
    – Yosi
    Commented Apr 14, 2015 at 11:26
  • I don't have evidence for this, but one possible explanation is that the SATA cable in the primary bay supports 6 GBps or other advanced communication features, while damage to the cable (or other difference) in the optical bay prevents these features from working there. Maybe Ubuntu can work around the lack of these advanced features, but OS X cannot. This is of course all conjecture.
    – Chris C
    Commented Apr 14, 2015 at 17:42
  • I agree with @Chris. The optical drive in my 2011 iMac has a transfer rate of 1.5G bps. There is a good chance the cable is also rated for just that speed. If I was to replace the optical drive with a drive rated at 6G bps, then I would expect hardware problems using the same cable. My guess is your Mac has a cable rated only for a 1.5G bps transfer rate. Commented Apr 14, 2015 at 21:57
  • How can I verify that my cable is a 1.5gbps transfer rate? and from where I can buy new cable that supports 6gbps?
    – Yosi
    Commented Apr 15, 2015 at 9:08
  • BTW - will this fix the problem for me? ifixit.com/Store/Mac/…
    – Yosi
    Commented Apr 15, 2015 at 9:14

In the off chance it is not a hardware problem with the cable, try creating GUID partitioned disk (GPT) with no partitions. This can not be done using the Disk Utility alone. To do so, follow these instructions.

Open the Disk Utility. Highlight the disk and click on the Info button. Determine the Disk Identifier. In the example below, I used disk2.

Close the Disk Utility and open a Terminal window. Enter the following commands. If prompted for a password, enter your login password.

diskutil  unmountDisk  /dev/disk2
sudo  dd  if=/dev/zero  of=/dev/disk2  count=40
sudo  gpt  destroy  /dev/disk2
sudo  gpt  create  /dev/disk2

Show below are my results.

Steelhead:~ davidanderson$ diskutil unmountDisk /dev/disk2
Unmount of all volumes on disk2 was successful
Steelhead:~ davidanderson$ sudo dd if=/dev/zero of=/dev/disk2 count=40
40+0 records in
40+0 records out
20480 bytes transferred in 0.021348 secs (959340 bytes/sec)
Steelhead:~ davidanderson$ sudo gpt destroy /dev/disk2
Steelhead:~ davidanderson$ sudo gpt create /dev/disk2
Steelhead:~ davidanderson$ 

If everything went well, open the Disk Utility and try to create and format a partition.

If successful, let me know if you need help installing Windows on this computer.

  • Hi, The gpt destroy didn't worked (gpt destroy: /dev/disk2: error: device doesn't contain a GPT), the format throw the same error "probing failed".
    – Yosi
    Commented Apr 14, 2015 at 11:31
  • Do you have another Mac available? If so try booting your Mac in target disk mode and connect it to another Mac. Try using the Disk Utility on the other Mac. This will eliminate the possibility the problem is with your OS X software. Commented Apr 14, 2015 at 22:04

I like to do things a little differently and this involves separating the problem into two distinct parts - OS and Hardware.

Let's look at hardware first. I like to use Ultimate Boot CD as it has a number of great utilities to test out your Mac. It runs on Linux so it completely eliminates OS X from the equation. And if you are wondering, yes, this will boot and work on your Mac. I have been doing it on Macs going back to 2006.

First, download, burn, and boot Ultimate Boot CD. There are a number of HDD utilities you can run that will test out your drive for you.

There is a USB Flash Boot Drive option instead of a CD (I personally use this).

Boot your machine by holding down the "Option" key before you hear the boot chime. You will then be able to choose your boot device.

There are a number of HDD tests you can run. Pick a simple test and run it.

Next, ff everything passes, try using a utility to delete/create a partition

If all works here, then you can attempt to create the bootcamp partition again.

Let us know what happens.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .