1

How is it that Disk Utility allows you to resize the partition that OS X is botted from live, while the OS is running? Can there be problems doing this? I would have thought that booting into recovery mode to do these things would be a requirement.

Here's what I mean, Disk Utility will allow me to "Apply" this change while booted in OS X:

enter image description here

I'm not sure whether clicking the "Apply" button is something safe to do while the OS is live. Is it? If so, how/why?

  • 1
    BTW - Pro tip… after Cmd/Shift/4 to take your picture, hit spacebar, then click the window you want & it will give it a nice clean border with drop-shadow. – Tetsujin Mar 7 '15 at 10:40
  • 1
    @Tetsujin Awesome, I will have to use that from now on! :D – trusktr Mar 9 '15 at 20:15
2

Although I don't know what specific property of HFS+ allows a user to modify the current system partition while in use; my expectation would be that operations to blocks of storage that the filesystem is not currently utilizing are allowed.

Now if you tried to shrink the system partition below the current size of your system installation (the blue shaded area) disk utility would present an error.

EDIT

Just wanted to add some additional information that I came across. If you refer to the diskutil(8) man page under resizeVolume it states:

Non-destructively resize a volume. You may increase or decrease its size.

A size of limits will print the range of valid values for the target partition, taking into account current file system and partition map conditions such as files in use and other (immovable) partitions following the target.

This seems to confirm my thinking above.

0

I discovered while in recovery mode that pressing "apply" when attempting to partition the disk that has been booted from shows an error message saying something like "cannot partition the disk that has been booted from". I imagine this will be the same error that appears while the system is live, but I didn't want to hit the Apply button to find out. Disabling the button and/or showing a tooltip would've been much more helpful.

  • Nope, it works fine when booted from the volume you're resizing. The reason you get an error in recovery mode is that in that case you're running from a hidden volume right after the main volume, and resizing the main volume requires that the recovery volume be moved. Resizing the current startup volume is supported, but moving it is not. That's why it fails in recovery mode but works when started normally. – Gordon Davisson Mar 9 '15 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .