10

I'm trying to screen share on from within the Messages app with another iMessage user. We're both on Yosemite, and we've successfully used Messages's new screen sharing feature many times. One day, we discovered the screen share button was disabled. It has never come back.

Screen sharing is enabled in the Video menu, and we are both on the most recent version of Yosemite. I'm not sure how to look for answers without even an error message to go on.

enter image description here

3 Answers 3

3

I just used Yosemite's screen sharing via Messages.

Getting it to work on both sides required me to enable back to my mac in System Settings under iCloud. After restarting the Messages app on both sides those two rectangles became active and screen sharing worked.

3
  • This worked for me after a serious amount of fiddling. Thanks!
    – Mathieu
    Jul 15, 2015 at 10:24
  • I don't know whether it was enabling Back to My Mac or whether it was also signing out of iCloud and back in. But I did both and remote Screen Sharing started working in both directions.
    – matt
    Mar 10, 2017 at 18:36
  • "Back to My Mac's security settings have been updated and require your password". Looks like a recent update turned it off. Re-enabling corrected the issue, thanks.
    – user
    Aug 2, 2018 at 19:22
1

I found that to get screen sharing to work, all I had to do is login to my iCloud account via preferences. After that the screen sharing icon was no long grayed out.

0

You should also ask your remote person to enable Screen Sharing via the checkbox in their Video menu.

Messages > Video > Screen Sharing Enabled

Stupid and obvious, I know, but I just wasted an hour helping someone before I remembered that that option existed.

Enable screen sharing in Messages

3
  • what exactly do you mean by "on the menu" Feb 10, 2016 at 18:01
  • I mean on the main OS X menu bar. I'm not seeing that menu item right now, which may because I'm not logged into any jabber accounts, or maybe it went away with the El Capitan upgrade? It definitely existed when I wrote my original rely (and was using Mavericks).
    – sclamage
    Feb 10, 2016 at 19:51
  • In Mavericks, Screen Sharing Enabled is in the video menu, but it seems to be different in Yosemite and El Capitan.
    – Charlie
    Apr 27, 2016 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .