3

I am somewhat new to caring for Macs, but one has been left in my care and I have not been able to restore it to working order yet. Here are the symptoms:

  1. The MacBook Pro would hang with a "white screen" during the boot process. A bit of boot splash would show up, but the gray background would at some point just hang.

  2. Booting recovery mode did not work, as far as I remember.

  3. Boot from a Ubuntu 14.04.2 USB stick works, provided one attaches "nofb nomodeset" to the kernel commandline (though I put that one down to insufficient driver support). I have no idea whether or not these usually work out-of-the-box.

  4. Using parted from the aforementioned stick, I was able to see three partitions, one EFI Boot, one large main partition and one labeled Recovery. It seemed strange that the recovery was recoognized as HFS+, as I expected, but the "main" partition was not mountable and did not show a filesystem type.

  5. I also discovered that the drive in question was an OCZ Vertex3 256 GB, which I assume is not standard? The previous owner could have upgraded it.

  6. At this point, I decided to wipe the drive and try with a fresh installation. I removed the SSD from the MacBook, pulled a full disk image from my desktop just in case (which went without any read errors) and used hdparm to do an SATA enhanced erase, leaving me with a "fresh" disk. Then I put it back in.

  7. I started internet recovery, which loaded, showing me the global and everything. Afterwards, it rebooted, showing me the Apple Logo. But then I run into the original "white screen" again.

  8. I've tried resetting the NVRAM on boot, which succeeded because it turned the boot chime back on, but even then, running internet recovery again just causes it to hang on the white screen.

  9. There seems to be either very high CPU or GPU usage on the white screen, as the fans start wailing pretty intensely, also the body gets very hot in a very short time.

  10. For funsies, I installed Ubuntu onto the MacBook, which works (after smoothing over a few hiccups, fortunately I have lot more experience doing that).

  11. Recovery mode (Cmd+R) and Apple Hardware Test (D?) I have not been able to run. The former suffers the same white screen issue as described above.

Currently, my only vague guess is a GPU issue, that may be circumvented by Ubuntu by using the not completely feature complete open source radeon drivers. But that is a wild guess. Any input is appreciated.

  • The problem has been solved at Gravis and Apple's non-open diagnostics tools: The hardware was actually broken and I got a free replacement. – stacked_deck Aug 13 '15 at 10:37
  • Now that these replacements are no longer an option the last ditch effort would be do something like this: GPU problem - Boot Hangs on Grey Screen – LangLangC Oct 17 '17 at 15:15
5

If your MacBook Pro was built around 2013, this is most likely a hardware fault to do with the actual GPU itself. It happened to me so I took it to Apple, they ran some diagnostic application on it and basically gave me a new, updated model. Apparently the problem is well known to them. I have some documents on the subject. I will edit/update this post if/when I manage to find the paperwork.


  • 2
    Turned out to be exactly that. – stacked_deck Sep 24 '15 at 4:10
  • GPU here - can confirm broken. Will be replaced. – VonSchnauzer Dec 2 '15 at 19:38
1

You might want to try using internet recovery again, completely erasing the disk using the supplied disk utility. (select the drive (not the partition) and use the delete tab. This will also recreate the partition map accordingly.

Also, try using safe boot (hold shift while booing). If that doesn't do the trick boot in verbose mode, which will give you more output about what's happening (hold cmd+V while booting).

Also try resetting SMC and PRAM

  • I have by now tried any combination of SMC and PRAM Reset, Internet Recovery and such. I was able to get a "no parking" sign, but other than that, nothing. – stacked_deck Mar 8 '15 at 21:29
  • No parking sign? – tjt263 Sep 17 '15 at 3:23
1

Just my 5c, may have nothing to do with, just a wild guess.

I have attached an encrypted USB harddisc with no OS to my MacPro. Every time I reboot, I need to press ALT for the boot dialogue, otherwise my MacPro is stuck within a white screen. When I detach the USB harddisc and reboot, no problem.

So how about just detaching all peripherals and try booting again...

0

Follow these steps to start up into safe mode.

Start or restart your Mac. Immediately after you hear the startup sound, press and hold the Shift key. Release the Shift key when you see the Apple logo appear on the screen. After the Apple logo appears, it might take longer than usual to reach the login screen or your desktop. This is because your Mac performs a directory check of your startup disk as part of safe mode. To leave safe mode, restart your computer without pressing any keys during startup.

Some features of your Mac aren't available when it's started in safe mode, so after you're done using safe mode you should restart your computer normally. For example, these features don't work in safe mode: You can't play movies in DVD Player. You can't capture video in iMovie and some other video apps. Some audio input or output devices might not work. Some USB, FireWire and Thunderbolt devices might not be available. Wi-Fi networking might be limited or unavailable depending on the Mac and OS X version you're using.

From Apple Support pages, provided from experience.

  • Hi, Welcome to Ask Different. Please consider adding links to the sources that support your answer. Thanks! – Jaime Santa Cruz Jul 2 '15 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .