9

So, I'd be using my Magic TrackPad or listening to music via Bluetooth headphones and suddenly the mouse cursor would start jumping around or the Bluetooth audio would start breaking up, and that's when I know that my colleagues iMac has connected to my computer. I go to the Bluetooth menu and I disconnect it. After a little bit or awhile, it connects again...

No one knows how or why this happens.

Could someone please tell me what's going on and how to stop it?

Oh, I forgot to mention, another one of our colleagues also complains about this particular iMac connecting to his MacBook Pro.

Update: immediately after posting this, it happened and I took a screenshot. Here it is

problem

Mahmoud's 27 iMac is the culprit.

Another update: Mahmoud's 27 iMac does not appear in the list of paired devices

problem

  • unpair/delete Mahmoud – Ruskes Mar 5 '15 at 3:11
  • @Buscar웃 see second update please. – M.K. Safi Mar 5 '15 at 3:16
  • ok, that is your BT-sharing OFF in the Sharing preferences P – Ruskes Mar 5 '15 at 4:21
  • @Buscar웃 Yes, BT sharing is off. – M.K. Safi Mar 5 '15 at 15:28
  • I have this same issue and it's driving me insane... a colleague's laptop keeps connecting to my computer and when it does it briefly disconnects my BT mouse / keyboard. – Hector Villarreal Sep 6 '18 at 18:18
3

I had the exact same issue and the culprit was an app I had installed called MacID, version 1.1. I deleted MacID and the problem went away but supposedly you can upgrade it and fix the issue as well

Reference: https://discussions.apple.com/thread/6702053?tstart=0

2

What happens when you select Mahmoud's 27 iMac in the Bluetooth menu? Does it show Connect to or Disconnect from Network, or something else?

I would bet Mahmoud's iMac is set up to share its internet connection over Bluetooth, which would probably also explain why it's not showing up in the Bluetooth devices list. Try looking under Network in System Preferences and see if Bluetooth PAN appears there. If so, click on it, and I think it will show Mahmoud's 27 iMac in the Devices list.

To disable this, on Mahmoud's iMac go to System Preferences > Sharing, click on Internet Sharing on the left-hand side, then either uncheck it (to disable sharing completely), or next to "To computers using:", uncheck the box next to Bluetooth PAN. If Mahmoud doesn't want to disable this, on YOUR computer you can go to System Preferences > Network, click on Bluetooth PAN on the left and click the minus sign at the bottom of the list.

  • Mahmoud's 27 iMac does not appear any where in Bluetooth PAN i.imgur.com/ohbz4lj.png Anyway, I removed Bluetooth PAN from my Network since I never use it anyway. – M.K. Safi Mar 5 '15 at 15:23
  • Oh, and to answer the first question, when Mahmoud's 27 iMac is connected to my computer via Bluetooth, the only option on the menu is "Disconnect". – M.K. Safi Mar 5 '15 at 15:24
  • 1
    I'm not sure who up-voted this. It doesn't solve the problem. – M.K. Safi Mar 9 '15 at 23:55
1

When the Bluetooth device is connected, press ALT/OPTION and click the Bluetooth icon. When you select the device in the list you will see a Remove option that should stop if from connecting in future.

enter image description here

  • I have this issue and there is no remove option for the Mac, only for the Mouse/Keyboard. – mgol May 23 '16 at 16:03
  • 1
    Actually, I tried to remove it a few times, it doesn't work. – Itachi Nov 10 '16 at 2:43
0

I faced the same situation and found that my colleague uses Notifyr app (http://www.getnotifyr.com/) which runs with bluetooth connection. I asked him to stop using the app, the problem seems to be solved in these two days.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .