Oftentimes, after I wake my Mac from sleep, powerd (which is the power management daemon? Which in particular deals with sleeping the Mac and waking it?) uses high CPU, usually around 25% to 50% on my i7 CPU.

Anyone know how I can find out what's causing it, and what I can do to fix it? It seems to be a problem with waking from sleep but I don't know what.

This problem started happening after I updated my Mac Mini to 10.10.2, a few weeks ago.

  • 1
    I would look in the Console to see what is it doing!
    – Ruskes
    Mar 4, 2015 at 18:11
  • I don't see anything relevant in the Console. There have been no relevant items in the past 30 minutes, and filtering for powerd shows one line: 15/03/04 12:27:27.000 am kernel[0]: PM response took 3152 ms (26, powerd) which seems to be when I put the Mac to sleep.
    – Gary
    Mar 4, 2015 at 18:41
  • How much Memory is it using ? I have it at 0 CPU and 1 MB memory
    – Ruskes
    Mar 4, 2015 at 18:47
  • powerd is at 25% CPU and 30 MB memory.
    – Gary
    Mar 4, 2015 at 18:54
  • hmm, type "power" in the console filter (not powerd) to see what is switching on/off, it should be Airport and HDMI ect..
    – Ruskes
    Mar 4, 2015 at 19:32

8 Answers 8

sudo kill -HUP $(pgrep powerd)

(I don't have an answer for 'why')

  • 20
    More succintly, sudo pkill -HUP powerd
    – danorton
    Jun 5, 2015 at 12:54
  • 1
    seems that it restarts on HUP, so just an ordinary TERM might do the same job. If only they'd documented anything about the daemon in the man pages.
    – jrg
    Oct 19, 2015 at 8:59
  • If @AndyDent is correct (below), then this is a non-problem, only active when you run ActivityMonitor to see if it's active. May 23, 2016 at 21:16
  • top -o cpu shows all processes running ordered by CPU. powerd with Activity Monitor running is (for me) ~15% cpu usage. Close Activity Monitor. powerd is now 0.1%.
    – Baker
    Nov 4, 2016 at 20:42
  • I just needed this answer, and might have a tiny clue about "why". This happened to me when my game that I am coding crashed with a segmentation fault. The OS is supposed to detect segfault and block it (and crash the program that caused it), I guess OSX isn't good enough regarding that and let my little game corrupt the system processes somehow. Or its own exception handling caused a bug in their own processes.
    – speeder
    Dec 1, 2016 at 20:28

sudo pmset schedule cancelall fixed it for me.

After updating from macOS Ventura beta 3 to beta 4, powerd was using 100% CPU even after restarting it.

pmset -g log repeatedly printed

2022-07-28 23:54:10 +0100 Assertions            PID 117(powerd) TimedOut InternalPreventSleep "com.apple.powermanagement.wakeschedule" 00:00:04  id:0x0xd00008a28 [System: PrevIdle DeclUser kDisp]          

pmset -g sched showed two scheduled events:

Scheduled power events:
 [0]  wake at 04/12/62 00:47:16 by 'com.apple.alarm.user-visible-com.apple.email.SendLaterDelivery' User visible: true
 [1]  wake at 04/12/62 00:47:16 by 'com.apple.alarm.user-visible-com.apple.email.SendLaterDelivery' User visible: true

pmset schedule cancelall removed these two and powerd CPU immediately dropped off.

  • 3
    This fixed it for me too. Happened after updating from Ventura beta 3 to beta 4
    – haidousm
    Jul 31, 2022 at 16:49
  • 1
    This worked for me (Ventura beta), thanks!
    – Adam
    Aug 5, 2022 at 2:34
  • 1
    And it's working on beta 5, to those who hasn't found this solution yet!
    – StevenRCE0
    Aug 9, 2022 at 9:04
  • This just fixed it for me as well, thank you! Aug 11, 2022 at 21:07
  • Have had this issue as of updating to Ventura Beta 5. After running your cancel all this fixed it. Aug 16, 2022 at 8:49

Have you tried to stop powerd by Activity Monitor? This solved the CPU consumption for me.

But after stopping powerd I got strange effect in Activity Monitor - it was like Update Frequency was changed from Often (2 sec) to Nonstop (0 sec), i.e. continuous without any delay. So I had to quit Activity Monitor too.

After these operations and restart of Activity Monitor all works fine.

  • From how you describe it, it doesn't sound like a good solution then. I agree that restarting the Mac is often the best way to fix these runaway processes.
    – Gary
    Mar 7, 2015 at 20:20
  • 1
    Not sure if full restart of Mac on every failure of some utility is rather good option. If that utility does not affect stability of the system.
    – std.denis
    Mar 7, 2015 at 21:10
  • Okay I'll kill it to see how that goes, next time. But I'm looking for a more permanent, long-term solution.
    – Gary
    Mar 8, 2015 at 3:04
  • 4
    I did the same thing, and saw what you were talking about in the Activity Monitor -- but if you look closely, you'll see that what's actually happening is that the Activity Monitor itself was backed up, and it is executing updates in rapid succession to try to catch up. Mine was backlogged for a couple days (on a little-used machine) it looks like and is taking awhile to catch up.
    – Kem Mason
    Jul 10, 2015 at 23:36

On my computer, it was Activity Monitor which caused the powerd process to use a lot of cpu (20-30%, sometimes 50%, resetting the SMC didn't help). Quitting Activity Monitor "solved" the problem. Checked in the Terminal by running top.

  • 7
    Doing a process sample of powerd suggest that Activity Monitor might keep fetching the energy impact info from it.
    – jturcotte
    Dec 5, 2015 at 17:34
  • Yep, worked for me.
    – rahmu
    Dec 12, 2016 at 17:45
  • Who'd have thunk it? I would never have thought that Activity Monitor would be responsible but certainly seems to be the culprit on my machine. Thanks for the suggestion. Jul 18, 2017 at 10:33

I use iStatMenus to monitor a range of things and it confirms that powerd is only using a lot of CPU whilst Activity Monitor is running. At other times, it does not appear on the high CPU users list.

  • 1
    I find this claim more than a little doubtful. It certainly does not match a logical evaluation of my experiences. 1) System is running slowly for some inexplicable reason. 2) Open Activity Monitor to investigate. 3) powerd appears to be the culprit. (Yes this doesn't contradict your claim, but...) 4) Kill powerd 5) Suddenly performance improves. (This strongly suggests powerd is the culprit, and perhaps iStatMenus is does not live up to you faith in it. ;)) Mar 5, 2018 at 11:41

You need to reset your SMC. Just like another answer i don't have the why but i have the solution.

 Mac mini, iMac, Mac Pro

Shut down your Mac, unplug the power chord, wait for 30 seconds, plug the power cord, wait for 5 seconds, start your Mac.


Shut down your Mac, press Shift+Ctrl+Alt first and then press the power button. It should not start. Take a look at the LED from your power cord and it should just change for few seconds. Then, release the Shift+Ctrl+Alt and start your Mac.

  • 11
    and the rationale?
    – hbogert
    Aug 31, 2015 at 13:11
  • 5
    Could you improve your answer so as to look less like prayer movements :).<br>How is diagnosed the "You need"?
    – dan
    Oct 20, 2015 at 7:18
  • 3
    Reseting the SMC doesn't help, it's restarting the computer that helps. The longest my uptime, the more powerd will take (only when Activity Monitor is running). I haven't restarted for 10 days now and it's taking 50% of one core. This goes away if I restart.
    – jturcotte
    Feb 5, 2016 at 15:34

On the Apple web page: Resetting the System Management Controller (SMC) on your Mac it is discusses when and why you should reset your SMC (System Management Controller). It doesn't mention this problem, but at least it lets you know a bit more about what resetting the SMC means!

I have this powerd problem too at the moment.

To reset the SMC on Intel-based Mac Pro, iMac, and Mac mini computers, you need to:

  1. Shut down the computer.
  2. Unplug the power cord.
  3. Wait fifteen seconds.
  4. Attach the power cord.
  5. Wait five seconds, then press the power button to turn on the computer.
  • 1
    Today I still had the powerd problem (25-45% use of a cpu). I shut down apps one at a time in case it was one app causing the problem, but powerd continued to hog a cpu. I then restarted, and that fixed the problem. As has been commented above, the activity monitor seemed to be playing catchup for a few seconds after the restart, showing data that was collected (I assume) before the restart. During this time the monitor updates came fast, and showed powerd still using 40% cpu. After a few seconds the monitor settled down, and powerd had disappeared from the monitor list of cpu users. Oct 8, 2015 at 16:00

I have the same issue with powerd using up more than one core of CPU on my 2019 16" MacBook Pro on macOS Catalina 10.15.7, and also making my system super slow (despite it "only" consuming a little over one core out of eight). [Edit: The issue is still present on macOS Big Sur 11.1.]

Solutions that did not work:

  1. sudo pkill -HUP powerd (it would immediately restart and resume hogging my CPU)
  2. closing Activity Monitor
  3. closing Intel Power Gadget
  4. unplugging all of my Thunderbolt 3 devices and power adapters
  5. rebooting
  6. resetting my SMC


So I opened up Console.app and noticed the following repeatedly:

Process powerd.154 TimedOut UserIsActive "com.apple.powermanagement.wakeschedule" age:00:00:01 id:38654738880 [System: DeclUser kDisp] macOS Console App repeatedly showing: Process powerd.154 TimedOut UserIsActive "com.apple.powermanagement.wakeschedule"


This tipped me off to this Reddit post. In it, u/iTim314 notes that he needed to go to System Preferences > Energy Saver > Schedule, and to specify something. I chose the least annoying values possible: enter image description here

After clicking OK, this immediately fixed my powerd problems. No more powerd warnings in Console.app, powerd was no longer hogging my CPU, and my system immediately became more responsive. If I uncheck both of these values and save again, the problem immediately reappears. And so on. (The Joker: "Ta-dah! It's GONE!")


Unfortunately, this is a workaround, not a true solution, but I'm hopeful this helps others figure out a proper solution or bugfix.


After writing this post, it hit me: This problem seemingly started occurring after I went into the "Energy Saver schedule" dialog two days ago. I took a look, checked (one or) both options, maybe saved my changes (I don't remember), then unchecked the options, and then maybe saved again (if I saved the first time). I've had this MacBook Pro for over a year now (and other MacBook Pros for over a decade) without experiencing this issue, so this probably isn't a coincidence. I'm left wondering if a corrupt .plist is being written for these settings...


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .