0

I have a Netgear Nighthawk R7000 Router with an attached HDD which I'm trying to access with the ReadyShare feature. I've created 3 shared folders:

  1. no_pass (no password required)
  2. pass_write (password required for write access)
  3. pass_read (password required for read/write access)

The problem is that while I can access folder 1 (no password) fine, I can't connect to 2 or 3 in finder because I'm getting a permission denied error. When connecting to server, I've tried each of the following:

  • smb://readyshare(/share_name)
  • smb://admin@readyshare(/share_name)
  • smb://admin:password@readyshare(/share_name)

I've done all the above with cifs and replaced readyshare with the ip address but while 'no_pass' will mount without a problem, 'pass_read' and 'pass_write' give

permission denied screenshot

Note: smb://readyshare or smb://192.168.1.1 will both show a list of the shared folders but again, only 'no_pass' will mount. The others give the same error above.

I can connect to all the folders using http or ftp so it doesn't seem to be an issue with the shares...

Any idea what's going on here?

(OS 10.10.2)

  • 1
    SAMBA implimentation on Readyshare drive has a 14-character limit password the RT7000 router. – user137327 Jul 22 '15 at 14:53
  • @the8habit Thanks, that explains one issue I was having but unfortunately it seems to be a limitation of the router. I have a (still ongoing) support case open with Netgear since February on this! – doovers Jul 22 '15 at 20:27
1

I had the same issue with my Netgear Nighthawk R8500 until I reduced the router's password to 14 characters, as suggested by user137327. Since the router's password is also used as the Samba password, perhaps the cause is related to the legacy of Samba and Lanman password limitations:

"passwords are limited to a maximum of only 14 characters"

"Many legacy third party CIFS implementations have taken considerable time to add support for the stronger protocols that Microsoft has created to replace LM hashing because the open source communities supporting these libraries first had to reverse engineer the newer protocols—Samba took 5 years to add NTLMv2 support"

0

No familiarity with that particular brand of NAS however I have a lot of experience with Windows (SMB) shares. So take this with a grain of salt (at least a medium sized one...)

Generally Windows authentication looks like this:

  • USERNAME: [DOMAIN][USERNAME]
  • PASSWORD: [your password]

Where the domain is the name of the NAS device. And use the backslash not "/"

When you try something like this:

SMB://readyshare

Do you get a password prompt? If not try:

CIFS://readyshare

CIFS is the fallback protocol when SMB does not work, but you often have to force it this way. Failing that it may be a name resolution (DNS) issue. Try it with the IP address instead:

SMB://192.168.x.x (or whatever the IP is)

If you get a dialog asking for a username and password try it in the format as above if just a username (without the domain prefix) does not work.

If none of that works, post what does happen wen you try and connect. If anything does post screen shots.

  • Hi Steve, thanks for the reply. I've done as you suggested but still getting same result. I've rewritten my question with more info and added a screenshot of the result. – doovers Mar 9 '15 at 5:05
  • Man that is a puzzler. We may have to take the nuclear option and contact the NAS vendor's tech support folks as I am out of ideas... sorry. – Steve Chambers Mar 9 '15 at 14:55
  • Yeah I've done that so I'm waiting to hear back from them. I'll report back here when it's resolved. Thanks for the help! – doovers Mar 9 '15 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .