3

I am trying to get into the Volumes directory.

Hidden files are being shown.

However, the Volumes folder won't let me access it, it's "greyed out". How can I bypass this?

closed as unclear what you're asking by bmike Mar 4 '15 at 15:50

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • In a Terminal, what is the output of: ls -l / | grep Volumes – user3439894 Mar 4 '15 at 1:34
  • drwxrwxrwt@ 4 root admin 136 Mar 3 20:20 Volumes – wgwz Mar 4 '15 at 1:35
  • In a Terminal, what is the output of: ls -l /Volumes – user3439894 Mar 4 '15 at 1:37
  • 1
    I'm placing a short hold on this since it looks like troubleshooting isn't done yet. Let's move the discussion to Ask Different Chat and see about editing this into one, two or three clear questions once we've collectively figured out what's being asked here. – bmike Mar 4 '15 at 15:51
  • 1
    Skywalker - please consider editing the post to explain what "get into" means. If this is the XY problem, just explain what the end result you wish to achieve. It appears you might be asking how to do X since you think it will get you closer to Y. – bmike Mar 4 '15 at 15:59
3

We need more specifics about what is going wrong. Do you have admin privileges on your computer?

Have you tried ⌘-⇧-G from the Finder and then typed /Volumes in that window?

enter image description here

You can also open a Terminal window, type cd /Volumes and then if that works type open . (a period).

If none of those work, then you need to set up that account with privileges to access root folders, but I think it should at least ask you to authorize when you try Go to Folder...


Edit: Just a guess, but from the Finder try going to the View menu > Show View Options (or press Command-J). At the bottom, click to show Library folder

  • Yes I have admin privileges (a.k.a the sudo password). I tried the Command-shift-G in Finder then typing in "/Volumes" but it doesn't bring me to right place. That brings me to "Macintosh HD". I want to be in Macintosh HD and then the hidden Volumes directory beneath it. The terminal command didn't do anything. When I run sudo cd /Volumes I remain in my home directory (where we see Documents, Pictures, etc.). I apologize, I can't upload screenshots at the moment my Imgur account is not working (fml.. I know). – wgwz Mar 4 '15 at 1:28
  • sudo just isn't necessary here as the permissions on /Volumes are 1777, everyone has read, write and execute. – user3439894 Mar 4 '15 at 1:28
  • @skywalker, you can upload images directly. – user3439894 Mar 4 '15 at 1:31
  • Apparently not because I can't access the Volumes directory from Finder. (Macintosh HD -> Volumes) No can do. – wgwz Mar 4 '15 at 1:33
  • 1
    @skywalker sudo cd will never work -- the sudo command runs cd as a subprocess, that subprocess changes directory to wherever you told it... and then exits, leaving the parent process (your shell) in the same place it was to begin with. – Gordon Davisson Mar 4 '15 at 2:04

Not the answer you're looking for? Browse other questions tagged .