1

I have a MacBook Air running Yosemite.

I have an external SD drive that I save files to frequently.

Info on SD drive says it's READ-ONLY all of a sudden? I am the ONLY person that uses this drive and it worked literally minutes ago!

  • I changed the title just to make it easier to google – Tetsujin Mar 3 '15 at 16:08
  • i have the same problem running OS 10.10.4, with couple of cards. – user150122 Oct 3 '15 at 14:21
2

Some SD cards' firmware will lock the device to read-only if any write error occurs.

If this happens, the only solution is to copy all data off it & discard.

SD/flash is not worth the effort of trying to fix, once it starts to go wrong.

Things to try…

  • Double-check the physical lock has not been flipped by accident.

  • Reboot the computer & try again

  • Try it on another computer/device

  • Once you have all existing data copied from it, attempt to format.

If none of this is successful, throw it away.

I work with hundreds of (admittedly very cheap) SD cards for work, & this is our standard practise if they start to fail.

Golden rule
Never store any important data on SD without having a safety copy on some more reliable medium.
I'd even extend that to - if you have to use SD to carry data from one machine to another - home/work etc - use 2 cards & keep them manually in sync with your work.

  • Thanks for the advice - no important data lost, just wanted to understand why/how this would happen so quickly. – Roy Hinkley Mar 3 '15 at 16:12
  • Welcome. Frankly, they're just flaky - work one minute, fail the next. Expensive ones tend to last longer, but not always. Some of the dirt cheap ones I use are still good after 5 years, with many many thousands of read cycles ; but we don't write cycle them much. idk if that makes a real difference. Some, of course, hardly last the day out before they start to error. [our cards go into continuous play advertising screens. No-one counts how many times one gets used, but they cycle for 14h a day, 7 days a week, playing the same 50MB or so video file, til they break] – Tetsujin Mar 3 '15 at 16:15
  • Before your comments, I would have thought a fail would cause it not mount at all - as opposed to read-only mount. – Roy Hinkley Mar 3 '15 at 16:29
  • It depends how badly it fails. Write-lock is 'intended behaviour' as a protective measure. Anything else could be controller fail or total fail of the flash itself. There's always the 'mess with it a lot & see if it works again' approach [I've just found it's not really ever worth the effort]. A number of versions of that here - apple.stackexchange.com/questions/65056/… – Tetsujin Mar 3 '15 at 16:37
0

All of my SD cards are suddenly giving this erroneous Read-Only message. It started wit the 10.10.3 update. Before that they worked fine. I have cards from different brands and sizes. The problem is with the MacOS X update having a bug. Older computers that do not have the 10.10.3 update do not have the problem.

0

What worked for me is putting my SD card into a camera (canon 60d) and using its format utility. It worked for me and the card works normally now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .