2

I'm running Yosemite, up-to-date on a mid-2012 MacBook Pro. I removed the optical drive, moved my internal HDD to its location and placed a new SSD in the original HDD's location. This has been great for a few months now. I've had a working Boot Camp setup that also was working fantastic.

Note that I removed my optical drive. I now have an external DVD drive I've been using for this.

Here's what I did:

  1. Installed ReFind. (Everything still OK)
  2. Disabled CoreStorage. (Everything still OK)
  3. Resized OS X partition down by 60 gigs, to leave room for Linux. (Everything still OK)
  4. Booted into live CD, and began installing Linux into that new, free space... It asked where to install the boot loader (GRUB) and I think this is where I screwed up - I let it just place it on the disk, instead of the Linux partition.

I tried the normal "Startup Repair" from the Windows 8 disk I have, which didn't help at all.

I tried everything at this location https://neosmart.net/wiki/recovering-windows-bootloader/ but it didn't help. Attempts 1 and 2 went through "OK", but didn't work. Attempt 3 actually gave errors at this line: bcdedit.exe /import c:\boot\bcd.temp. Not sure why.

ReFind still works great, OS X still works great, but I can't get into Windows and Linux ... well, it's installed, but GRUB doesn't exist.

Top priority for me is fixing Windows, I can get Linux going later. Any help?

  • And my partition table looks a little nutty in Disk Utility. See here: imgur.com/F1Dog35 The 60gb between OS X and Windows seems to be "claimed" by OS X, and now I have two small partitions after Boot Camp. Both of those showed up as "EFI" in DISKPART, but now they just seem .. normal. And broken. – The1nk Mar 3 '15 at 4:03
  • I assume by now you have fixed this problem. If not please respond. – David Anderson Apr 1 '15 at 14:58
  • @DavidAnderson I wiped everything (but Mac) and just re-installed Windows. Ended up foregoing linux entirely. So, no. – The1nk Apr 2 '15 at 20:14
  • The reason I asked is because I just installed a triple boot of OS X 10.10.2, Windows 7 and Fedora 21 Workstation Linux. All 3 are the 64 bit versions. The machine was a 2011 iMac with a 1/2 TB harddisk. I also successfully installed rEFInd on its own partition. It appears you tried to install linux between OS X and Windows. If this is true and your Windows was using a BIOS boot, then you were doomed to failure. Anyway, what type/version of linux were you trying to install? Is windows using a BIOS boot? How to you plan to use both internal disks? I may post an answer if I think it could help. – David Anderson Apr 2 '15 at 23:16

You must log in to answer this question.

Browse other questions tagged .