I added lustyExplorer to ~/.vim/plugin. Then I ran MacVim and tried to run it with ":LustyFileSystemExplorer". Error

"Unknown Function: lustyExplorer#LustyFileSystemExplorerStart"

In the documentation it says:

"                 <Leader>lf  - Opens the filesystem explorer.
"                 <Leader>lr  - Opens the filesystem explorer from the
"                               directory of the current file.
"                 <Leader>lb  - Opens the buffer explorer.
"                 <Leader>lg  - Opens the buffer grep, for searching through
"                               all loaded buffers
"               You can also use the commands:
"                 ":LustyFilesystemExplorer [optional-path]"
"                 ":LustyFilesystemExplorerFromHere"
"                 ":LustyBufferExplorer"
"                 ":LustyBufferGrep"

I also tried :lf and got Error:

can't open errorfile errors.err

Am I executing it correctly? What does the prefix <Leader> mean?

  • From the docs: "This plugin requires Vim be compiled with Ruby interpretation." So does MacVim have Ruby support? To check run: mvim --version | grep -i ruby
    – Ian C.
    Mar 3, 2015 at 1:02
  • Yes, I already checked this. Mar 3, 2015 at 1:13
  • Dead set on using this? I'm a big fan of NERDTree for a file explorer and I recommend using Vundle as your plugin install in *vim.
    – Ian C.
    Mar 3, 2015 at 6:26
  • So far I've tried peepopen and lustyexplorer and both of them are broken :). I'll try NerdTree next I suppose. Mar 3, 2015 at 13:33
  • 1
    I really recommend using Vundle to manage the installs of your plugins.
    – Ian C.
    Mar 3, 2015 at 19:42

1 Answer 1


If you have dowloaded the file from github seems to be incorrect. Use the download link in the plugin page lusty-explorer.vim that works as expected

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .