1

I have a MacBook Pro and I partitioned the internal SSD into two parts (150GB and 50GB). One of them (the 50 GB part) contains a bootcamp with Windows 8.1. I also have an external hard drive, which is 1 TB with both USB 3.0 and Thunderbolt connections. I partitioned this into to two parts also (500GB and 500GB). One of them is formated for Windows and the other is for Mac.

Since I don't have too much space on the bootcamp internal hard drive (50 GB) I installed MSVC2013 on the external hard drive's Windows part. After the installation I learned that I didn't save too much space, but it worked and I had no problems with it. Since I didn't need it anymore I uninstalled it, but then for some reason I had to install it again. For some reason when MSVC2013 was uninstalled I changed the external hard drives Windows partitioned part's driver letter to a different one. When I tried to install MSVC2013 again it didn't let me, since it wanted to install it to the same place where it was before and I couldn't change the installation path, because it was grayed out. I read it in some forums that this is a "normal" behavior from MSVC2013 and to change the installation path you need to format the whole OS. Formating at that time was not an option for me, so I thought I create a small partition from the external hard drives Windows partition with the driver letter what MSVC2013 wants. I created the partition with Disk Managment in Windows and the installation was able to finish. MSVC2013 worked again.

After all this I went back to the Mac part of my internal hard drive and I realized that now on the Mac side it doesn't recognize the Mac part of my external hard drive. In the Mac's Disk Utility it shows the part, but it is grayed out. So I went back to Windows to see if the Mac part of my external hard drive is recognized there and I learned that it is. So I thought I make a fast copy of all my data of the Mac part of the external hard drive and then the strange thing happened.

Some of my files were able to be copied and some were not. The folders which were not copied were unreachable. This is the error message what I get when I try to access them.

Anybody has any suggestion how could I reach these folders? All help would be much appreciated!

  • did you try the disk utility repair? – Ruskes Mar 2 '15 at 20:43
  • Yes, I did...and it failed unfortunately! – Silex Mar 2 '15 at 21:02
  • "created the partition with Disk Managment in Windows" That was the start of your problems. Windows doesn't understand how the Mac disks are set up & will break things if allowed to touch the partition structure. See apple.stackexchange.com/questions/171050/… – Tetsujin Mar 3 '15 at 7:57
  • Yes, I read this post, but is there a way to somehow save my content on the Mac part, before I proceed as it is mentioned in that post? – Silex Mar 3 '15 at 15:37
0

This piece of software recovered all my lost files!

Data Rescue 3 External Drive Recovery By PROSOFT Engineering, Inc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .