I have an iMac (27-inch, Late 2013) that has a 4-pole TRRS headphone/headset combo port. On OS X any headset works nicely (e.g. the Apple iPhone headset with microphone).

On Windows 7 64bit with BootCamp 5.1, the same headset on the same combo port does not work with the driver as delivered by Apple with BootCamp 5.1 (more precise: 5.1.5640 ). Apple phone support just told me it is not their problem, because it works on OS X.
So I tried installing a better driver on my own.

According to the Windows Device Manager, my sound card is a Cirrus Logic CS4206B (AB 07). The closest match I could find on the Cirrus homepage was this one:
(Go to Resources -> Tools and Software).

The same page is also linked in this related thread, including a step-by-step installation guide, but it doesn't work for me. Did someone get a 4-pole headset to work including the microphone on an iMac with the Cirrus Logic CS4206B (AB 07) sound card?


5 Answers 5


Not sure if people are still having a problem with this as it's been almost a year, but I was running into this problem with my Mac mini 2014 with Windows 10 Home and Bootcamp v6.0. The sound card is Cirrus Logic CS4208 (AB 108), and I couldn't get Windows to recognize the mic on my headset which was designed for iPhone/Apple usage.

After not being able to find the driver for the CS4208 (AB 108) at a legitimate site on the net (results almost always required a 3rd party driver downloader - no thanks!), I went to Cirrus Logic's website and tried to search for another driver. I was able to find CS4207 from their website, downloaded the zip file, and tried to update the CS4208 driver with files on this zip. The driver was taken, and, after a restart, the microphone now showed up (even though it was still showing CS4208 AB 108). It works!

I even rolled back the driver and updated again to confirm it works, and it sure does! I also have another 2016 MBP that I would like to test. Will update here after.

Here's a few screenshots before the driver update to CS4207: Driver-BeforeRecording-Before

And after updating the drivers and restart: Driver-AfterRecording-After

  • 1
    MacBook Pro has no problem. It has the Cirrus Logic CS8409 (AB 57) card, and when I looked in the Recording tab of the Sound Pref, it already had 'Internal Microphone' and 'Microphone'. The 'Microphone' was showing as 'Not plugged in' and as soon as I plugged in my headset, it was working right away...
    – oms
    Oct 16, 2018 at 18:22
  • Great answer. Saved my days. Otherwise I would have to boot into Mac whenever I need to use the mic.
    – dnang
    May 29, 2019 at 2:21
  • Thanks, this technique worked for my mac mini with the latest boot camp and windows 10.
    – Magnetoz
    Mar 8, 2020 at 16:13
  • Downloading and installing the CS2407 Drivers from Cirrus Webpage did it for me! Thanks a lot! Jun 26, 2020 at 19:56

This worked for me. It was a Windows privacy issue: https://www.youtube.com/watch?v=ZssiZtyKaNk

You can test by recording your voice with the Voice Recorder Application. Give it permissions from Settings > Privacy Settings > Microphone. Also make sure Windows has permissions to use the microphone.

  • This is almost entirely irrelevant to the question. Changing privacy settings will not help if the driver doesn't allow for an external microphone to begin with.
    – oKtosiTe
    Aug 12, 2018 at 0:24
  • Just left this answer here since I also thought my driver was faulty and it wasn't. I also reinstalled the windows driver and it still didn't work. I was trying everything and it turned out to be a privacy setting that didn't allow windows to use the microphone for any application including windows. I think it's at least worth a try, it worked for me on a macbook pro mid 2014 Aug 13, 2018 at 1:09
  • 1
    The privacy setting is also the only blocker to using my internal microphone CS4208 on MacBookAIr7,2 booting Windows 10 with UEFI. Apr 22, 2020 at 10:55

If people are still having this issue in 2019 and have USB-C ports on their Mac, Apple's USB-C to 3.5mm adapter seems to fix this issue. While it doesn't work on macOS, it certainly allow you to use the microphone on Apple Earpods (and the in-line controls) and other headsets. The adapter is $9 in US and is mainly for iPad Pro 2018. I hope this helps, as it works perfectly for me!

Or if you have an Xbox one controller with a 3.5mm jack (I'm not sure about ps4 controllers) you can use that as a USB sound card


According to https://discussions.apple.com/thread/6767136 this is currently not possible. If someone does get it to work I will happily award a bounty to an answer describing how to do it.


It appears that Windows 10 running the latest Bootcamp does recognize the TRRS microphone now:

Hi there. I've been monitoring and looking for a solution for this for sometime and it seems the latest version of bootcamp released today (Bootcamp 6.0) with Windows 10 fixes the problem.

I had Windows 10 installed through bootcamp and updated to bootcamp 6 today (Aug 13). Surprisingly, I plugged in my iPhone headset (which is TRRS) and noticed windows installing some drivers. ...

Headset is working just like it does in OSX now, awesome for VOIP or gaming. Very happy camper here!

Should note that I am running Windows 10 with Bootcamp 6 on a late 2013 Retina Macbook Pro.

  • Doesn't help those with older versions of Windows, though...
    – Adam Davis
    Mar 16, 2017 at 16:12
  • I have the latest Windows 10 Pro 64 bit and the latests Bootcamp (it just says Versio 6.0), but my headset does still not work. Is there anything else I would have to consder? Does it depend on the cable? The headset? The Mac?
    – matth
    Mar 17, 2017 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .