If you delete a file, but it's still in use (e.g. a document still open), and then try to empty the trash you get something like this:

Emptying trash, file in use dialog

As best I can tell the three options do the following:

  • Skip: ignore this file and keep trashing the rest
  • Stop: stop trashing files
  • Continue: ignore this file and keep trashing the rest

As far as I can tell, Skip and Continue do exactly the same thing. I've tested this by deleting a few files, and using either option they seem to trash all the other files.

But it seems weird that Apple would supply two buttons which do exactly the same thing.

So does anyone know of any technical difference in the behaviours of the Skip vs Continue buttons?

I'm using 10.10.3 Yosemite, but I believe the options have been like this for a few major versions.

  • 5
    As an aside, I find the presence of any options to be a bit silly. I can't really imagine using Stop, because its only protecting some of the not-in-use files (any already trashed before this one got caught 'in use' are gone), and you've already confirmed you want to trash everything. So of the 3 options, 2 seem to be identical, and the other pointlessly confusing. I think it should auto-continue and just show an error that some files couldn't be trashed. – drfrogsplat Mar 2 '15 at 5:01
  • That is very odd... – Flare Cat Jan 22 '16 at 1:49

I couldn't find any documented proof but still, here is my answer.

When you first hit above shown error, it means you can

  • Skip i.e. don't try to trash mentioned file and continue trashing the rest
  • Stop i.e. stop trashing for now
  • Continue i.e. you have closed mentioned file (it's not in use anymore) and OSX can continue trashing it

If you just click continue or fail to close the open file, OSX skips them and hence the confusion.

Most of the in-use files I have seen are plists which needs to be unloaded before deleting

Extra info after some experiment:

Above said is mostly true in situations when trash contains plists or in general you trashed some app

For example:

If you create a text file → Open it → Trash it while the file is still open → Try empty Trash → No problem i.e. Trash empty without any error and file still open

But If you start some app (like MAMP in my experiment) → Launch it & start services → Trash the app → Try empty trash → You will get the above said error → Open activity monitor → Kill all related services & hit continue → Trash empty

enter image description here

  • I just tried this and it didn't work. I ran cat > testfile from the command line, deleted the testfile, emptied the trash (it complained as above), killed the cat command and then hit continue, but the testfile was not trashed. – drfrogsplat Jan 25 '16 at 1:26
  • At times it won't even complain even the when the file is open. Running 10.11.3 and just tried what you did and no complains, file is still open and trash is empty. What I said above is the most logical thing I could come up with as I have explained, I don't have any documented proof for this – pun Jan 25 '16 at 1:33
  • @drfrogsplat I've more info after some experiment, hope it answers your question/doubt – pun Jan 25 '16 at 2:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .