2

I have a Mid-2012 15" MacBook Pro running OS X (Yosemite) 10.10.2. It has a 2.6GHz Intel Core i7, 8 GB of RAM, and a 750GB HDD.

Over the past couple of weeks it has become incredibly slow, to the point that simple actions such as clicking on an icon in the dock have caused the spinning wheel to appear. As far as I can tell nothing significant changed around the time that this behaviour started.

There is nothing unusual shown in Activity Monitor: CPU usage is low and there is over 6 GB of free memory with no swap being used.

Some example of the degree of slowness are:

  • Scrolling down the page on an already loaded page in Chrome - Spinning wheel for 30 seconds
  • Clicking in text field on Github in Chrome - Nothing happens for 34 seconds
  • Refreshing a page in Opera - Spinning wheel for 27 seconds
  • Opening Calendar from the dock - 70 seconds for Calendar to open, no visual feedback
  • Clicking to focus open Pages document - Nothing happens for 21 seconds
  • Opening System Preferences and clicking Keyboard - Spinning wheel for 30 seconds
  • Clicking on the File menu in Finder - Spinning wheel for 23 seconds
  • Swiping up with three fingers on the trackpad (show Mission Control) - Nothing happens for 12 seconds
  • Moving cursor down a single line in vim - Spinning wheel for 12 seconds

I have tried the following:

  • Turning it off and on again
  • Making sure everything is up-to-date
  • Performing a disk repair
  • Resetting the SMC
  • Resetting the PRAM

Is there anything else I can try to fix this?

Edit: Unbelievably enough I somehow didn't think to check the logs. Doing so shows the following message occurring regularly. Does this mean that my hard disk is damaged, despite the fact that the disk repair claimed to have fixed any issues?

kernel: CoreStorageGroup::completeIORequest - error 0xe00002ca detected for LVG "Macintosh HD" (C9D97BC3-3A2E-405E-BE14-0E9B3FAD7A0D), pv 90103BF0-50B3-455D-947E-A020BC46F680, near LV byte offset = 161931108352.
kernel: disk1: I/O error.
  • Please post the specs of your Mac (esp. RAM installed), post Activity Monitor screenshots (CPU/RAM), possibly related log file entries (Console) and check /var/vm – klanomath Mar 1 '15 at 8:55
  • Question updated. Can't believe I forgot to look at the logs. – DanielGibbs Mar 1 '15 at 9:09
  • The common disk repair doesn't fix damaged blocks nor other hardware related errors (damaged controllers/cables etc.). So check the S.M.A.R.T status - you might have to config/install smartmontools. Probably it's at least 1 bad block though. – klanomath Mar 1 '15 at 9:17
  • The smartmontools long test reported a status of Completed: read failure so it looks like I do have some bad sectors on the disk. Thanks for your help. – DanielGibbs Mar 1 '15 at 18:57
  • 1
    You might erase the hdd to map out bad sectors. Better replace it with a new one – klanomath Mar 1 '15 at 19:00
1

Don't waste even a second because your HDD is for sure suffering from a few bad sectors. I had the same problem, after two days of dealing with a very slow Mac, it failed to boot and I had to regenerate bad sectors of HDD using software available on the market. Really time consuming and risky procedure in case your data on HDD is important.

0
  1. You might want to give Onyx a spin: http://www.titanium.free.fr/onyx.html

  2. SMC reset: turn off Mac and press ⇧ + Ctrl + ⌥ + Power-Button for 5 seconds

  3. PRAM reset: turn off your mac, turn on mac and press ⌘ + ⌥ + P + R. You'll hear the startup chime and reboot will start again. Wait until you heard the startup chime the third time and then let your mac boot.

Not sure if this will solve your trouble but it is the standard debugging steps.

UPDATE: if your harddrive is broken, make a backup as quickly as possible if you don't already have one. Buy a new harddrive, set it up and exchange.

TechToolPro might be able to help, but that software is just as expensive as a new harddrive if you're not buying an SSD.

  • Did you read the question? I've already tried resetting the SMC and PRAM. – DanielGibbs Mar 1 '15 at 18:51
  • 1
    So did you try Onyx? Or TechToolPro? How's the backup situation? As others pointed out, as long as this potentially damaged HDD is still running, I'd use every second, to secure my data and prepare a replacement. – foss Mar 2 '15 at 8:54
0

For me I believed the problem was League of Legends XD. Im not exactly sure why but I do remember there was a file called Kernel within the application...But as soon as I deleted the game...boom problem solved and the error was gone. Took me a while to figure out the problem, hopefully I this helped some of you with the same problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .