1

I can't start any programs or open any document from the spotlight since yesterday.

It finds the right program / document, but when I press enter I only get the spinning beachball for about 40 seconds and then spotlight closes without opening anything.

Any ideas?

  • 1
    I have now installed Alfred and set it CMD+Space. This seems to work until I find a solution for the problem with Spotlight. – rmweiss Mar 3 '15 at 20:48
  • I "solved" the problem with reinstalling from Time Machine. This seems to have reseted whatever caused the spinning beachball. Should I close the question now? I mean for me the problem no longer exists, but I still have no Idea what really the problem was. – rmweiss Mar 6 '15 at 21:22
2

For future reference. I had the same problem, but found this solution:

  • Back up. (You should always have a backup.)
  • In Finder, select the menu: Go ▹ Go to Folder... and enter:
    /var/db/CoreDuet
  • Delete the files inside that start with coreduetd. In my case it was 3 files.
    • Enter your Administrator password when prompted.
  • Reboot your Mac.
| improve this answer | |
1

I have experienced the exact same issue since few days as well (AFAIR about 2 days ago), and am trying to find a solution.

This is what my OSX Console log (Apps > Utilities > Console) looks like, just after selecting a program / document in spotlight results:

04/03/2015 14:29:27,288 WindowServer[202]: disable_update_timeout: UI updates were forcibly disabled by application "Spotlight" for over 1.00 seconds. Server has re-enabled them.
04/03/2015 14:29:41,289 WindowServer[202]: disable_update_likely_unbalanced: UI updates still disabled by application "Spotlight" after 15.00 seconds (server forcibly re-enabled them after 1.00 seconds). Likely an unbalanced disableUpdate call.
04/03/2015 14:30:11,296 Spotlight[4186]: Hang timer fired; exiting
04/03/2015 14:30:11,299 spindump[1433]: Got xpc error message in libspindump client connection: Connection invalid
04/03/2015 14:30:13,675 Spotlight[4294]: applications query - started
04/03/2015 14:30:13,808 Spotlight[4294]: applications query - finished in 0.13 seconds

System: OS X 10.10.2 Yosemite

Issues seem to start about right after having installed Duet Display and rebooted.

However, there's one thing that can be done to isolate spotlight issues and that's to run the command sudo /usr/bin/mddiagnose and either dig into the collected error logs or forward them to your support chain (Apple Support if you don't have a support team/IT department).

So:

  1. Open terminal.app (by navigating to /Applications/Utilities in Finder if needed)
  2. Run the command mddiagnose
  3. Reboot
  4. Check to see if spotlight is still hung: repeat the mddiagnose each time it hangs to get a sense of how often this happens
  5. repeat as needed

That tool will package all the system logs surrounding the event as well as check for crashes and specific error messages that might point to the cause of spotlight hanging.

| improve this answer | |
  • I've edited in a bit about mddiagnose - if anyone has a repeatable case, hit me up in the chat room and I'll see if I can guide you through the output of that tool. Anyone that's really interested could ask how to parse the logfiles that the tool generates... (hint hint) – bmike Mar 4 '15 at 14:50
  • After following everything explained in that thread (discussions.apple.com/thread/6757500), and having the same issue with a guest account, in safe mode, etc., I ended up reinstalling OSX: support.apple.com/kb/PH18872?locale=en_US This solved my issue with spotlight, and I kept everything else (apps, prefs, etc.). Just keep in mind this'll take a long night... – Julien Ma Mar 5 '15 at 10:50
0

Removing /var/db/CoreDuet/coreduetd.db*

coreduetd.db
coreduetd.db-shm
coreduetd.db-wal

files worked for me, I have tried everything else suggested everywhere but this actually worked.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .