3

Having had a hard drive failure, I'm attempting a clean install of Yosemite on a 2010 Mac Pro, with a brand new 120GB OWC SSD.

I've tried using a Yosemite boot disk, using both an external hard drive and a USB memory stick, which both suffered the same symptoms, and now I'm seeing something similar with an old Mavericks USB memory stick, which I believe has worked before.

The problem I had with the Yosemite install was that it would start the installation, I'd accept the terms, and it would get to the "Preparing to install" screen. It would then count down from 8 minutes, stop at "1 second remaining" for about 10 minutes, then "0 seconds remaining" for about another 10 minutes, before finally presenting the error message, "An error occurred while preparing the installation. Try running this application again."

With Mavericks, I'm seeing the same thing up to the "0 seconds remaining" problem, but then it just hangs - on the last attempt I waited about an hour, and I'm in the middle of a second attempt now.

I've tried resetting the PRAM, and checked the date in the terminal which is correct (albeit the wrong time zone, but I'm guessing that's not important).

The only entry in the Installer system log is:

localhost Install OS X Mavericks[387]: Can not connect to /var/run/systemkeychaincheck.socket: No such file or directory

Any advice much appreciated!

  • Since you have the bootable usb stick, boot from it, then use the disk utility to check your OWC disk for errors. – Ruskes Feb 28 '15 at 18:38
  • Thanks for the suggestion - I should have mentioned that I'd done that (several times!), and it had reported no problems. I'd also tried 2 separate brand new drives, so was fairly confident it wasn't an error with the drives; still not sure why it didn't work, but it's fine now, so all is good :) – DaveyDaveDave Feb 28 '15 at 18:53
  • did you also try formatting the disk before running the install. What disk info does it show? – Ruskes Feb 28 '15 at 19:15
  • Yup, I formatted it every time as MacOS Journalled. I can't remember what the disk info showed, but it's working now, so it definitely wasn't a problem with the disk. – DaveyDaveDave Mar 1 '15 at 8:38
1

Not a brilliantly helpful answer, but a resolution nonetheless.

I contacted OWC's online chat tech support, who were incredibly helpful - continuing the conversation for an hour and a half - and talked me through diagnosing the problem.

The tech support rep first suggested using my old boot drive, and from there, testing whether my SSD was writable via the OS. The setup of this Mac Pro was 1 boot drive, plus 3 RAIDed drives. I found that with the RAID card still in, I couldn't access the SSD, but after removing the RAID card, and resetting the PRAM again, the SSD appeared and was certainly writable.

I don't think the RAID card was part of the original problem, because I'd tried installing without it as well, but getting feedback that I could write to the SSD was very encouraging!

I then simply tried installing Mavericks from the USB drive while already booted using the old boot drive and it worked!

So - as far as a solution for someone else encountering the same problem, I'm not sure what I can suggest, other than - if you can - boot normally, and install it that way, having selected the new drive that you want to install on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .