0

I'm trying to paste these Chinese letters: 你好世界 to my Terminal, but instead I've got "^L" or some other weird characters.

The same happens for other unicode characters (such as £āēīōūśṣṭēīōū) when pasting or pressing Option+e, then a for á, e for é, i for í and similar, then I've got C!C)C- instead.

In Terminal Settings, I've got Character encoding set to Unicode (UTF-8) (Preferences/Settings/Profiles/Advanced) and in Encodings tab I've UTF-8 enabled.

I've LANG=C, however setting it to LANG=en_GB.UTF-8 doesn't help.

However it works when I run echo:

$ echo -e "\xE2\x98\xA0"

My Terminal settings are:

Terminal Settings on OSX

I'm using Terminal v2.4 on OS X Mavericks (10.9.5). My shell is bash.

How I can configure Terminal to support Unicode characters?

  • works fine at default settings for me. I'm no terminal guru so I've never changed any settings in there. I can't find that Emulation pane though, where is it? EDIT...What OS are you on, I found the prefs but no Emulation header. – Tetsujin Feb 27 '15 at 18:49
  • I'm on OS X Mavericks (10.9.5). Terminal v2.4. – kenorb Feb 27 '15 at 18:51
  • I'm on Yosemite - essentially, the same prefs settings [other than Bell, which is unlikely to be the kicker] I also have VT100 checked; I'm guessing that ain't it either. – Tetsujin Feb 27 '15 at 18:52
  • @Tetsujin Emulation pane is in Preferences->Settings. choose your Profiles and Advanced tag. – kenorb Feb 27 '15 at 18:53
  • Yup - I found it, it just doesn't say Emulation, it says Input on Yosemite - threw me for a minute – Tetsujin Feb 27 '15 at 18:54

You must log in to answer this question.

Browse other questions tagged .