2

I just recently upgraded to XCode 6.1.1 from 5.1.1. When I launch iOS Simulator. I get an error "Unable to boot device in current state: Creating". I have tried deleting the devices and adding them back manually. But that is to no avail. I have reinstalled XCode as well after uninstalling and cleaning my Library and Preferences folders. That also has not worked. I am not sure if there are artifacts left over from 5.1.1 that are causing this.

Does anyone know what the root cause/solution is?

Please Advise

3

This error can happen if you renamed Xcode.app. I suggest you do the following:

  1. Quit Xcode.app, iOS Simulator.app, etc.
  2. Execute: sudo killall -9 com.apple.CoreSimulator.CoreSimulatorService
  3. Execute: rm -rf ~/Library/*/CoreSimulator
  4. Reboot and try again.
0

What do you find when you go to XCode > Preferences > Downloads?

You may need to update the simulators within this preference.xcode downloads

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .