1

I have problem with zsh at command line for non English language characters but after enter key the language show the right word.

~   
❯ สว<0e31>สด<0e35>
สวัสดี
zsh: command not found: สวัสดี

i was check the locale everything is utf8

locale
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

and check if any fonts, it's have same problem. i use zsh version 5.0.2 and oh-my-zh

1

Well, I found the answer.

Open ~/.zshrc file and add this option below at the end of file:

setopt COMBINING_CHARS

Then restart Terminal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .