2

I recently discovered this nice little spotlight feature in that you can convert a number of bytes into a human readable format. E.g you can type 2147483648 bytes and it will give the corresponding number of "gibibytes" in the preview window. (I think it's documented somewhere that it can do conversions "like" calculator, but the standard calculator doesn't have a conversion for bytes, so this feature seems to be undocumented).

But the strange thing is that now the preview on the right pane of the spotlight window is fixed to the last conversion I did. That is if I do a new conversion (that is any conversion like $ in € not just byte conversions) I see the result in the preview pane, but I cannot see any previews of selected search results anymore even when I change the search term:

Broken spotlight preview

I'm not sure when it got broken, I don't think it was right after I tried my first conversions. But anyhow this is a pretty annoying bug so how can I fix this?

3

Try deleting the spotlight cache folder at ~/Library/Caches/com.apple.spotlight

  • 1
    Cool, that worked. But I also had to kill the /System/Library/CoreServices/Spotlight.app/Contents/MacOS/Spotlight process (probably a restart would have also worked). Anyway, thanks for the hint! – David Ongaro Feb 26 '15 at 2:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .