If I use that green button to maximize a window

enter image description here

it will enter full screen mode and move my window to a new "virtual" display to the right (those which you can switch by swiping with three fingers on the touchpad). If I click the green button again, it will leave fullscreen mode and move back to the initial display.

I'm wondering if there's a way to make the fullscreen application stay on the same display it used to be before maximizing (or even better to disable multiple displays per monitor at all).

The reason I would like to do that is that if I e.g. watch a video with the VLC media player I usually do so in fullscreen mode. Then I close the program with CMD+Q and it switches back to the first screen. After opening another video it will start playing the audio only but the video is being displayed on a different screen which is rather confusing, because I have three physical monitors attached and each of it got multiple virtual displays.

1 Answer 1


If you hold the 'option/alt' key the green button functionality will be changed to fullscreen.

  • 1
    Good one I just tried that and it keeps it on the same display but unfortunately it won't go to fullscreen then. I basically just would like to keep the window on the same "virtual display".
    – beta
    Feb 25, 2015 at 15:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .