5

I have an MBP with Yosemite connected to my home network, and I want to automatically mount three hard drives located on a Windows 8 computer also connected to the network.

When I connect using "Finder->Go->Connect to server...", OS X remembers my user name and password, so all I have to do is this move three times, one for each hard drive on the Windows computer in question.

But I don't want to manually add these drives every time I log in or restart the Mac. So I add these network drives to "System Preferences->Users and Groups->My Name->Login Items" by simply dragging their icons from the Desktop to the item window.

But upon login or reboot, OS X doesn't remember the user name or password, and prompts me for it. And it doesn't help that I tick the "Remember password in Keychain" box.

EDIT: There are three keychain entries for the server (whose name is "HTPC"): internet password, network password, and certificate. The relevant entry in this case is, I guess, the network entry. It does have the correct account name and the correct password for the server. But I begin to suspect something else is happening here, since the logon dialog (that says 'Enter your name and password for the server "HTPC".' has 'Name: christer.tamm' when the keychain entry has 'Name: christer.tamm@gmail.com'. I'll try changing my user name in Windows 8, perhaps OS X doesn't handle the '@' character as it should. /EDIT

EDIT II: I tried supplying another account to log on with, this one without an '@'. Didn't work either. But then I just deleted ALL keychain entries to 'HTPC', and tried the same procedure as in the beginning of this tragic story. Lo and behold, it now works as it should. So while I am pretty clueless as to exactly what was wrong, deleting all the entries helped solving the problem. /EDIT II

What is going on here? Am I doing something wrong? Why doesn't OS X behave as I expect it to?

  • What do the keychain entries for each server indicate? I have two SMB shares which auto-mount using the Login Items method which doesn't work for you. – IconDaemon Feb 25 '15 at 15:52
  • Thanks for setting me on the right track. No longer a problem for me, although I still don't understand exactly how OS X handles the keychain info. – Christer Tamm Feb 25 '15 at 20:50

You must log in to answer this question.

Browse other questions tagged .