1

When trying to open either Word or Excel, I get an error saying

Microsoft Word (or Excel) cannot be opened because of a problem. Check with the developer to make sure Microsoft Word works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application and OS X.

I believe the two applications update in the background occasionally, but they were working fine until mid-last week.

1
  • Same problem here (though with 10.10.5), but not only with Office. My TextWrangler.app is also having this problem, which makes me think that it isn't a MS Office problem. I uninstalled and reinstalled TextWrangler, but that did not fix the problem. Have you found a solution to this problem? – Nicojo Sep 15 '15 at 8:45
1

I've tried myself and can confirm that Office 2011 works for OS X 10.10.2. I would recommend that you uninstall Office and then install it from your installation disc or redownloading it from Microsoft if you bought it as an online download.

0

I'm not sure what your exact problem is but I would try reinstalling just to omit that possibility from the list.

My copy of Microsoft regularly updates itself too and so far they're working perfectly. Although there WAS this one time back when I upgraded to Mavericks that a reinstall was necessary but it doesn't seem to be the case for me now.

Just for the sake of clarification, Have you tried contacting microsoft about the issue? Also which version did you purchase? Office for Mac Home & Student or Office for Mac Home & Business?

0

Office 2011 is working fine for me too in MAC OS X 10.10.2. As Dempa said, reinstall Office 2011 and make sure that you install all the updates as with the release of Yosemite Microsoft made 2 updates in a row of the software.

0

I had the same problem with the brand new Outlook 2011.

Something within the update to 10.10.2 broke the SQLite library functions, so an older database cannot be read properly.

You may need to recreate the primary office identity using the app "Microsoft Database Utility".

(Note: I run the german version, so you need to adapt the names.)

Close all applications and make a backup of your current ID:

Home ▸ Documents ▸ Microsoft (User Data) ▸ Office 2011 Identities

and copy your identies there by duplicating them.

Go to and open

 Applications ▸ Microsoft Office 2011 ▸ Office ▸ Microsoft Database Utility

Select ID to rebuild and hit the "Rebuild" button. That takes a while...

Logout and login again and fire up Outlook and afterwards Expel, Prowlerpoint and/or WOT. :-)

2
  • 1
    For me, "Microsoft Database Utility cannot be opened because of a problem." :( – Nicojo Sep 15 '15 at 8:46
  • Same problem here, not even Microsoft Database Utility works, I'm running Sierra.. weird thing is that it was working after upgrading to Sierra – yorch Dec 11 '16 at 0:29
0

Reinstalling MS Office 2011 for Mac will not solve your problem if you are using an Office 365 subscription. I spoke with Microsoft tech support yesterday and according to her, "the 2011 software is not compatible with such a new system and have been causing issues with customer's Office software." Office 2011 for Mac is not compatible with Yosemite and Microsoft's answer is to wait for the 2016 version, which "they are working on releasing by the end of the year."

This is odd as I have 2 other Macs in my household that are running Office on Yosemite. It seems to be an issue with the sign in / registration process. I am not sure if having a license key would bypass this issue...

2
  • 1
    The MS tech support comments sound like nonsense. I run both 2011 via 365 sub and 2016 Preview without problems. – Tom Gewecke Apr 8 '15 at 15:18
  • I'm also running both 2011 and the 2016 Preview on 10.10.2 (and 10.10.3 Dev. Preview) without any problems - don't believe everything you hear :) – Rene Larsen Apr 8 '15 at 15:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .