25

When I try to save a new file in TextEdit, I always get a popup saying I can't save with ".txt" at the end of the file name.

I want to save a plaintext file, but TextEdit insists on saving as .rtf instead. It also lists .doc, .odt, .html, and some others.

How can I save a TextEdit document as plain text?

0

1 Answer 1

32

The format menu has a toggle to switch things for you.

Pressing shift + command + T will toggle the document to plain text mode. Screen Capture showing the Make Plain Text menu item for Text Edit

You can also set the default format in the preference pane for the app.

Mojave dark mode screen capture of Text Edit preferences showing the RTF / TXT radio button preferences

3
  • Great Answer! This is absolutely absurb, that Apple do not provide .txt as a file type option out of the box. To have to change preferences to enable.txt is crazy. especially for an application called "TextEdit" Jul 15, 2022 at 1:35
  • Do note that the best part of this answer is the second picture showing how to turn on .txt in preferences. The first part of this answer is a workaround. And it would be good to describe: Firstly save as rtf, then convert to txt, and then paste in your plain text. then save again, now you will have 2 files, and can delete the rtf. Jul 15, 2022 at 1:39
  • @TheArchitecta: I just created a new doc, pasted in some text, clicked "Make Plain Text" in the Format menu (as shown in the first image in the answer), then went to save the file – and it defaulted to saving that file as .txt. You don't actually need to save the file as .rtf in the first place – though if you had already saved it as .rtf, then presumably it would indeed create a new file when you saved the plaintext version as .txt. (The second part of the answer is just explaining how to change the default format for new files.)
    – V2Blast
    Feb 28, 2023 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .