2

Hardware: Mac mini (Late 2009)

OS: Yosemite 10.10.2

Problem: cannot read CDs/DVDs, either by internal drive or external drive.

...

When you insert any type of CD or DVD, ISO, UDF, HFS, original media or not, the Mac mini tries to read for a few seconds, between 15 and 30, and then ejects the media. Only the blank media remain on the drive, so the Finder when Disk Utility can identify them, but when you try to write something, the disc is ejected.

I've tried several tips found on blogs, but nothing can make the Mac mini read the disks.

I've tried also my external drive, an external USB case with DVD-RW from LG, IDE bus, which works perfectly on my PC with Windows 8.1 and Linux OpenSUSE 13.2, and also works perfectly on my old war buddy, a PowerBook G4.

My Mac mini simply refuses to read discs, either by internal as well as external drive by! Yosemite's fault?

Does anyone have a solution or something that could help me find a way to understand and solve this problem?

disc burning info

  • Had the same problem turned out to be hardware. Can you check the voltage for the external drive and make sure no other stuff is plugged in? – bdecaf Feb 25 '15 at 6:56
  • The problem is only with the optical reader. Putting a HD in USB case, it works normally. I tested it with a reader from Samsung in the same USB case, same problem, Yosemite continues ejecting any disk inserted. Also tested with another USB case and the same problem persists. Yosemite just ejects the disc. Noting that both USB cases, both with the optical reader from LG and Samsung, functioning normally under Windows 8.1, Linux and Powerbook (with Mac OS X Tiger). – ElvisVinicius Feb 25 '15 at 12:34
1

Mine did the same, however after purchasing an LG external drive Mac/PC from Best Buy, I am now successful in reading disks. I use the cable that came with it on the back of my Mac Mini USB port. This is the cheaper one, and has flimsy CD tray, but works.

0

Everyone's solution seems to "clean the stupid dvd tray" or "buy another external stupid drive". The realitiy is that it is a problem with the OS updates. How would you explain that the drive works fine in bootcamp on the Windows side and it doesn't on the Mac side ? Pretty annoying and Apple support is null.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .