1

I followed the instructions here: Stop TextEdit to iCloud Save

defaults write -g NSDocumentSaveNewDocumentsToCloud -bool false

However, after a period of time, Textedit reverts back to blocking when I try to open or save a file. How do I stop Textedit from doing this once and for all?

I am using Yosemite 10.10.2. At first it's okay, then after a period of time, this default goes away. Also my host name keeps changing to 'new-host-3' or 'new-host-2.'

3
  • FWIW as original answer poster: I wrote that answer a long time ago, yet I believe it is still just as valid. The commands in the linked question write to the same preferences that are used in the latest version of OS X and should still function correctly. – grg Feb 24 '15 at 16:33
  • 1
    FWIW It's my understanding that starting with OS X 10.9 and later changes made to .plist files using defaults are not always immediately available to the environment and may necessitate logging out/in for changes made under a user account or a reboot for global changes if you want then to take place immediately. – user3439894 Feb 24 '15 at 16:50
  • Please edit in the version of your OS X as well as explicitly the exact strings you entered. If the old Q or A gets edited, your post will no longer be able to stand alone. – bmike Feb 24 '15 at 17:40

You must log in to answer this question.

Browse other questions tagged .